Here's the environment:

  1. Linux(x64): 16.04
  2. MongoDB: 3.2.15


root@system-test:~# mongo
MongoDB shell version: 3.2.15
connecting to: test
2017-07-25T07:31:28.528+0000 W NETWORK  [thread1] Failed to connect to, in(checking socket for error after poll), reason: errno:111 Connection refused
2017-07-25T07:31:28.530+0000 E QUERY    [thread1] Error: couldn't connect to server, connection attempt failed :

exception: connect failed

When I tried to see the status I get this:

root@system-test:~# sudo service mongodb status
● mongodb.service - High-performance, schema-free document-oriented database
   Loaded: loaded (/etc/systemd/system/mongodb.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-07-25 07:45:32 UTC; 1min 8s ago
  Process: 1721 ExecStart=/usr/bin/mongod --quiet --config /etc/mongod.conf (code=exited, status=14)
 Main PID: 1721 (code=exited, status=14)

Jul 25 07:45:32 system-test systemd[1]: Started High-performance, schema-free document-oriented database.
Jul 25 07:45:32 system-test systemd[1]: mongodb.service: Main process exited, code=exited, status=14/n/a
Jul 25 07:45:32 system-test systemd[1]: mongodb.service: Unit entered failed state.
Jul 25 07:45:32 system-test systemd[1]: mongodb.service: Failed with result 'exit-code'.

How it happened:

I tried to stop MongoDB and did the following

sudo service mongo stop [This didn't work].

Then i tried kill - 2 <PID> [Seem didn't worked too]

But after this command #mongo stopped working and getting the above error.

Please help guys

  • 1
    Please attach last 20 lines of MongoDB log file – Priyanka Kariya Jul 26 '17 at 12:23

sudo service mongo stop [This didn't work]

As MongoDB BOL mongo is an interactive JavaScript shell interface to MongoDB, which provides a powerful interface for systems administrators as well as a way for developers to test queries and operations directly with the database. mongo also provides a fully functional JavaScript environment for use with a MongoDB.

And mongod is the primary daemon process for the MongoDB system. It handles data requests, manages data access, and performs background management operations.

As simple language we can say that mongo is shell interface for MongoDB. And mongod is server , which handles data requests, manages data access, and performs background management operations.

So, in place sudo service mongo stop it should be the below mention command

sudo service mongod stop

As MongoDB documented Here Some of basic procedure to check MongoDB services in RHEL is as mention below:

Start MongoDB

sudo service mongod start

Stop MongoDB

sudo service mongod stop

Restart MongoDB

sudo service mongod restart

Verify that MongoDB has started successfully

sudo chkconfig mongod on

Begin using MongoDB

Start a mongo shell on the same host machine as the mongod

mongo --host

As your service mongodb status tells, your mongod process don't exists. So, if you try to connect (with mongo -program) to your mongod, you cannot.

So, restart your mongod sudo service mongodb restart, try now to connect it mongo.

If you want to see what happens when you shutdown, start following mongodb.log tail -f /var/log/mongodb/mongodb.log and then in other terminal say sudo service mongodb stop, some times shutdown process can take quite long time.. As startup process too.


I also ran into same issue. But was able to resolve by completely removing mongo first

sudo apt-get purge mongodb-org*

Then performing following

sudo apt update
sudo apt install -y mongodb
sudo systemctl status mongodb

You can refer to following link for the same: https://www.digitalocean.com/community/tutorials/how-to-install-mongodb-on-ubuntu-18-04


This question is for Linux, but for fellow windows users who found their way here and want a windows solution...

the problem is your Mongodb service is stopped. So do the following steps:

    1) cntrl-alt-del and open your task manager
    2) click on 'services'
    3) scroll down to MongoDB
    4) right click and hit 'start' (or 'restart')

go back to your mongo.exe file and your mongo shell should work now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.