0

User DB is in SUSPECT state.

sp_who2 shows that is isn't being used in any SPID.

I cannot ALTER to SINGLE_USER. I have a FULL+DIFF backup combo that I restore from, but without exclusive access, I cannot restore.

ALTER DATABASE failed because a lock could not be placed on database 'MyDB'. Try again later.

Tried to DROP, having closed connections - no joy.

Tried RESTRICTED_USER just in case - no joy.

Am I missing something really obvious, or do I need to take more drastic action? (Such as restarting SQL with everyone disconnected from every SSMS on the planet... (developers on multiple continents))

Any assistance is hoped for...

Thanks!

Addendum

I should add that the transaction log filled up the disk.

All attempts to backup the existing TLog fail due to SUSPECT presence.

1

The SQL Error Log message, "During undoing of a logged operation in database 'MyDB', an error occurred at log record ID (541478:273336:241). Typically, the specific failure is logged previously as an error in the Windows Event Log service. Restore the database or file from a backup, or repair the database." proved to be accurate, AFTER freeing up significant quantities of transaction log drive space.

Thanks to all who so swiftly applied their expertise in answer to this (never seen before by me) problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.