I'm trying to start LaunchPad service but it fails to start with:

Error 1053: "The service did not respond in a timely fashion"

I've been reading this was common in RC versions but I'm running SQL Server 2016 SP1 + CU3.

I've tried to add the SQLRUserGroup to the LogOnLocally user right assignment. The service still not run.

Also, there is no log in folder: C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Log\ExtensibilityLog

I've tried to change security of log folder including the NT Service\MSSQLLaunchpad and the SQLRUserGroup entries.

Any suggestion is appreciated

UPDATE: It was fixed reinstalling the SP1!

UPDATE2: We reproduced the issue simply by following these steps: install SQL 2016, Update it with SP1, Add R Services using the installation (no SP1).

  • Thank you for updating the original question. On SQL 2017, reinstalling the latest CU (after installing ML services) worked for me. – Dave Mason Mar 8 '20 at 20:29

I has this issue, this tutorial did the trick for me.


Should be noted an easy work around for me was just to change the account to NETWORK SERVICE in config manager, if you're not fussed about using a dedicated account for security reasons it will likely work for you also.

  • Neither solutions have worked :( – Dan Aug 2 '17 at 11:53
  • I'd to also add NT Service\MSSQLLaunchpad to Administrator group, and then I did started the service (and then the installation continued. I had the issue even in the installation process) – Dario Quintana Jun 14 '19 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.