-1

Under the Registered Servers window, I switched to Reporting Services and created a new server registration. By way of trial and error I figured that the Test button would succeed if I entered http://ip_address/ReportServer for the server name (the IP alone or a full URL of the SSRS ASMX would not work), chose Basic or Forms Authentication and provided the user name and password. Then it tested Okay and saved.

Now that I am trying to connect to the newly registered server, I get the following error:

TITLE: Microsoft SQL Server Management Studio
------------------------------

Error connecting to 'http://192.168.0.4/ReportServer'.

------------------------------
ADDITIONAL INFORMATION:

Value does not fall within the expected range. (Microsoft.SqlServer.Management.UI.RSClient)

I noticed that after I save the new server registration, the Authentication drop down always reverts to Windows Authentication and blanks out the user name and password, even though I am specifying Forms/Basic, testing that successfully, and saving thereafter.

What am I doing wrong?

  • Use windows auth and server name syntax should be servername\instancename. – Daniel Björk Aug 2 '17 at 15:40
  • To use Windows auth I would need to be a user on the SSRS server, which is not the case. – ajeh Aug 2 '17 at 15:46
  • Then someone who are need to configure basic or form authentication and add you in such way before you can use them. They are not default settings for SSRS. – Daniel Björk Aug 2 '17 at 15:49
  • Read the section about register a report server. docs.microsoft.com/en-us/sql/reporting-services/tools/… – Daniel Björk Aug 2 '17 at 15:51
  • And you don't need to be a user in the server but you need to be added as a user in SSRS to be able to connect. – Daniel Björk Aug 2 '17 at 15:55
-1

enter image description here enter image description here

Form and Basic login must be configured before you are able to use them and SQL Login is not supported. https://docs.microsoft.com/en-us/sql/reporting-services/security/authentication-with-the-report-server

  • When using the syntax you proposed, the login times out. And the saved server is still reverting to Windows auth. What am I missing? – ajeh Aug 2 '17 at 15:36
  • You need to use Windows auth like i wrote or Configure form or basic. – Daniel Björk Aug 2 '17 at 15:37
  • Do you know the instance name? – Daniel Björk Aug 2 '17 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.