There are several ways to use a Dark Theme on SSMS main coding window, either importing a vsettings file, applying Dark Theme that is disabled on a config file or doing it manually. But all those options do not affect Grid Results, Object Explorer and other windows. Those 2 are the main ones I use other than the coding one.

I tried the usual Tools>Options>Environment>Fonts and Colors then selected on the combo box Show settings for: the option Grid Results and using White for Item Foreground and Black for Item Background. Saved, restarted SSMS but just the text is white, background is still white.

Any idea on what is happening or how to do it? I can't find how to do it for the Object Explorer.

SSMS Fonts and Colors configuration


4 Answers 4


These options are ignored as of SQL Server 2005 SP2 and still not fixed.

See the relevant connect item: SP2: Results Grid Background color property ignored by Management Studio. archive link

The status is closed as fixed, but only because it's been converted into an internal issue

Thanks for this feedback. I have converted this request to either a defect (something is broken) or a Design Change Request (something new to add to the product) and so I'll close this ticket out. We will consider your information for SQL Server 2008 or a subsequent release. Thanks!
- Buck Woody, SQL Server Program Manager

There is a second connect item: SSMS 2012 Grid Results background color does not work (unfortunately not archived) which is closed as wontfix.

Hello Chris. Thanks for the feedback. We triaged this issue and at this time do not plan to address this in a future version of SQL Server.
-Walter A Jokiel, Program Manager, SQL Server ([email protected])

There is however one user commenting

I found the answer! This is actually controlled by the tooltip color you set up in your windows environment. Man, That was a PAIN to find!

But unless that works I fear you are out of luck


As Tom's answer said, it was a bug in older versions of SSMS that kept the grid results background color from having an effect. This was fixed in SSMS 18.0:

Fixed an issue where the grid result background color was being ignored.

However, it's still not very good if you want to make the grid results background a dark color. The biggest problem is that cells with NULL still always have a light yellow background. If you change your grid results text to a light color to go with the dark background in most cells, the NULL cells will look horrible. There are other minor problems too, like the gridlines and border of the window pane not looking quite right with a dark background.

I've started using an SSMS plugin called SQL Shades that does make all interface elements dark in a reasonable way. It's not perfect either. You can't customize the colors used for the results grid and I had to disable the dark-mode on the connection dialog because it was causing a weird flickering. But it is completely useable and is much better than what you can get with just the built-in SSMS settings.

By the way, the reason that the actual Dark theme doesn't fully work even when it's enabled is because the theming is a feature of Visual Studio, which SSMS is built on top of. However, SSMS adds a lot of UI elements that don't exist in VS (such as the results grid), so the VS themes don't affect them.

  • I tried out SQL Shades and it worked good. NULLs now have a nice blue background that is easy on the eyes but reads well. You can also adjust the brightness of the grid lines!
    – Vaccano
    Commented Jan 26 at 20:11

Visual Studio 2017 has Dark theme and supports SQL queries. Results are shown in white text on black background (except for the heading line, which is black text on white background).


The issue has been fixed in SQL Server Management Studio 18. I've downloaded it and I am able to change the grid results colors :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.