I'm trying to deploy a tabular model to a server using the "Analysis Services Deployment Wizard".

When attempting to deploy,I get the below error.

The JSON DDL request failed with the following error: Failed to execute XMLA. Error returned: 'The column 'Date Offset' in table 'Date' has invalid bindings specified.

The column in question uses the below calculation, which was found here

INT([Date] - TODAY())

What should I look for in order to resolve this error?

5 Answers 5


The problem in this case was that I was trying to replace an existing column also named 'Date Offset' - this was not a calculated column, but taken from the source table.

Resolution was to do the deployment in 2 phases, first remove the old column, then deploy again to add the new calculated column.


I was able to solve this by deleting the cube completely off of the server before doing another deploy.


Tried different methods like renaming column and removed filters applied, didn't solved this issue. At the end this issue fixed by just deleting existing cube and redeployed


In my case, I remove duplicated columns and the error persisted.

It only worked when I did delete model in azure --> analysis services.


So I had this error and I was able to resolve it by deleting the column from the model.bim. You have to be careful and make a copy of the model.bim before you start making changes. Then I created the calculated column and gave it a new name and it worked fine.

I hope my answer helps others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.