8

I recently got a new dev box, got my Visual Studio installed. Got my SSMS installed. Started writing some procs and tables... no intellisense help.

Whaaa??

All the boxes are ticked. I'm in the right DB. I get the red squigglies if the table doesn't exist, but I have no flyout for object name completion. Surely I messed something up because my googling tells me 2017 has much improved intellisense capabilities.

Nov 06 2018 Update

I removed my own answer saying that caching had been the culprit, because it still seems super flaky on what will and won't allow auto complete. I can hop back to an earlier version of SMSS and get the kind of of snappy results I was used to until this version.

I've started using Azure Data Studio for day to day stuff. It's super snappy. Lots of QoL improvements. Not even close to enough features for server management, but lots better for general proc writing and data analysis.

  • What rights do you have to the database you are connected to? – Max Vernon Aug 29 '17 at 16:10
  • I have sysadmin – meteorainer Aug 29 '17 at 18:36
  • 1
    If you right click on the query editor, is the "Intellisense Enabled" line/icon enabled? Also, are you using CTRL + Space to trigger intellisense? The Database also has to support it. Here is a quick debugging site for Intellisense: mssqltips.com/sqlservertip/2591/… – MguerraTorres Aug 29 '17 at 21:08
  • @meteorainer It might be helpful to specify which 17.x version you had issues with - they've been releasing quite frequently. Also, the SSMS 18 Preview 4 that is currently available seems to have a way more responsive Intellisense in my experience with it thus far. – LowlyDBA Nov 6 '18 at 16:52
  • @meteorainer if you're going to keep updating your question, you can just put those as an answer, since these updates are more of work-arounds than any additional info on your question. – LowlyDBA Nov 8 '18 at 19:02
7

What ended up working for me was setting the "Statement Completion" options in Tools -> Options -> Text Editor -> Transact-SQL -> General -> Statement completion section -> turn on Auto list members and Parameter Information.

Pic of where the options are located

  • 2
    Excellent. This worked for me. I had been using CTRL+J to trigger the list members until I found this post. – SomeGuy May 23 '18 at 14:33
  • Thank you, worked for me. Was driving me crazy. – melegant May 15 at 16:04
2

Having just spent two days with the same problem, I finally found the answer (in my case). Intellisense does not work in SQLCMD mode, and mine was on by default (Tools, Options, Query Execution, SQL Server, General, second last!)

1

Now I'm not stating that this is the solution, but I have encountered various issues with various versions of SQL Server Management Studio if SSMS cannont retrieve Microsoft's Certificate Revocation List from the internet.

This is a rule that is checked during the installation of some Microsoft products; including, but not restricted to:

  • Microsoft SQL Server
  • Microsoft SQL Server Management Studio

The error message text is normally displayed in some form as:


Results of Rule Test


Rule "Microsoft .NET Application Security" generated a warning. The computer cannot access the Internet. There might be delays in starting a .NET application like Management Studio. If navigate to http://crl.microsoft.com/pki/crl/products/MicrosoftRootAuthority.crl and are prompted to download the MicrosoftRootAuthority.crl file you should not have .NET security validation issues. It is not necessary to download the MicrosoftRootAuthority.crl file.

Solution

Although the rule doesn't seem to relate to Intellisense issues at all, downloading the MicrosoftRootAuthority.crl file from the location specified in the error message and installing it into your trusted certificates, can alleviate some of the issues surrounding SSMS and performance.

0

This is probably a shot in the dark, have you tried clearing (maybe back it up first) the contents of %appdata%\Microsoft\SQL Server Management Studio\{Version#} and then restart SSMS?

0

After experiencing this issue for weeks and attempting everything above with no luck, I finally got IntelliSense working again. My (bizarre) solution: Open a new query, use the icon on the menu bar icon (a few icons to the right of 'Execute') to toggle IntelliSense off, then immediately toggle it back on. Works like a charm.

  • I had tried that back when first asking the question but it didn't work for me. It's still super spotty on what it will and won't let me auto complete. – meteorainer Nov 6 '18 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.