1

I want to create an alias in SQL Server Configuration Manager. I can navigate to "Aliases" in the tree on the left, and I can right-click to open the context menu when "New alias..." is an option. When I click "New alias...", I get the following window:

enter image description here

All of the fields are grayed-out and uneditable. Is this a bug in SQL Server Configuration Manager, or am I doing something wrong?

This is SQL Server 2016 Standard. I was able to create an alias previously so I do not know why this is not working. I have tried multiple workarounds, such as opening Configuration Manager as administrator, and running the 64-bit version of the SQLServerManager13.msc.

  • 1
    Are there multiple instances (with different versions) installed on the server, or did you ever perform an in-place upgrade against this instance? – John Eisbrener Sep 1 '17 at 18:01
  • 1
    There are two instances, one named instance of SQL Server 2014, and one instance with the default name (MSSQLSERVER), which is SQL Server 2016. I recently added the 2014 instance, and I was able to create aliases before, so perhaps that is the problem. – Sam Magura Sep 1 '17 at 18:07
  • 1
    I have tried running both the 32-bit and 64-bit versions of SQLServerManager13.msc directly from Powershell, and the issue persists. – Sam Magura Sep 1 '17 at 18:09
  • There is a note in books online If a configured alias is connecting to the wrong server or instance, disable and then reenable the associated network protocol. Doing this clears any cached connection information and allows the client to connect correctly. – SqlWorldWide Sep 2 '17 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.