My VM ran out of disk space and MySQL wasn't able to write to the log file causing it to crash. Here is the log file:

2017-09-05T11:47:00.636352Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M

2017-09-05T11:47:00.650903Z 0 [Note] InnoDB: Completed initialization of buffer pool

2017-09-05T11:47:00.654252Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().

2017-09-05T11:47:00.667475Z 0 [Note] InnoDB: Highest supported file format is Barracuda.

2017-09-05T11:47:00.669522Z 0 [ERROR] InnoDB: Ignoring the redo log due to missing MLOG_CHECKPOINT between the checkpoint 72827846847 and the end 72827846656.

2017-09-05T11:47:00.669553Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error

2017-09-05T11:47:01.270002Z 0 [ERROR] Plugin 'InnoDB' init function returned error.

2017-09-05T11:47:01.270053Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

2017-09-05T11:47:01.270064Z 0 [ERROR] Failed to initialize plugins.

2017-09-05T11:47:01.270071Z 0 [ERROR] Aborting

I've tried to remove the ib_log* file in /var/lib/mysql and set innodb_force_recovery = 3 in my.cnf file. But received the same error. Any help appreciated.

  • Did you try innodb_force_recovery values 4, 5, 6?
    – akuzminsky
    Commented Sep 7, 2017 at 3:57

1 Answer 1


Was able to do a mysqldump, remove everything. Do a clean reinstall of mysql and import it back. Thanks for the help !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.