We have a recommendation from performance audit to "enable the "NoDelay" parameter on our database". I searched through Microsoft documentation and found that this parameter is configurable with SQL Configuration manager :


enter image description here

However, there is no "no delay" option configurable :

enter image description here

I also search through database advanced options and Windows Registry without success. Google shows some pictures with the option :

enter image description here

Any idea how to enable this ?

We are running SQL 2008 R2

Microsoft SQL Server 2008 R2 (SP2) - 10.50.4000.0 (X64) Jun 28 2012 08:36:30 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 6.1 (Build 7601: Service Pack 1)

  • But what do you expect from enabling it? There is already No Delay, so what you'd like to change with it? – sepupic Sep 6 '17 at 10:54
  • @sepupic I do not know if there is already "NoDelay" set to "yes" or not – Mickael Sep 6 '17 at 11:09
  • 1
    Can you ask for more information from the auditor, exactly what they mean? This is long but interesting thread (old but relevant), you might find useful. groups.google.com/forum/#!topic/comp.databases.ms-sqlserver/… – SqlWorldWide Sep 6 '17 at 11:44
  • I think that option is removed in more recent versions but I can't find any documentation except the one you linked to stating "doesn't support this" and older ones stating "you shouldn't touch this" but I can't find any real documentation stating it was removed at some point, so maybe you should ask the auditor as SqlWorldWide suggested – Tom V Sep 6 '17 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.