1

I'm running MySQL (MariaDB) inside docker container and with every start, it shows the following warning:

[Warning] 'proxies_priv' entry '@% root@mariadb-3702996102-qbr18' ignored in --skip-name-resolve mode.

So, it writes the current container hostname in proxies_priv and since I have option skip-name-resolve in my.cnf it gives the warning.

Is there a way to hide this warning? Perhaps there's an option to not write the hostname variant to proxies_priv?

2

The warning is useful because it tells you that this proxy privileges will never be matched.

Your options are:

Update

Just tested MySQL 5.6 and MySQL 5.7, and it seems that even if the warning appears, localhost is replaced by 127.0.0.1 with --skip-name-resolve. A bug was opened: https://bugs.mysql.com/bug.php?id=81441

Clearly MySQL should only warn if the domain isn't localhost, as with a disabled resolver the rule won't apply at all, only @your.ip.address.number and @localhost would work.

3
  • It seems this was enough for the OP, but I'm stumped. How can I fix this, or is it something that should just be ignored? – Codemonkey Sep 5 '18 at 14:52
  • @Codemonkey I really think you can ignore it. Test it with mysqltuner.pl that's the best way to find out about security and performance issues. – Yvan Sep 6 '18 at 15:04
  • Yeah it's that that complained about it, but only in a non-specific nature about warnings in my startup log file – Codemonkey Sep 6 '18 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.