I have Firebird 2.5 classic server running on Windows 7 on port 3059. This service is set to automatically start up and it works fine.

I've installed Firebird 3.0.2 as classic server on port 3050 but service won't automatically start. I can start it manually but I really need it to start automatically.

Error 1053: "The service did not respond in a timely fashion"

is the error I get in Event Viewer. Windows has only one, administrator user, without password. That's only error.


1 Answer 1


This could be that your system just has too much going on at initial boot or maybe the 3.0.2 service shares some resources with the 2.5 service and is running into a timeout that clears itself by the time you are able to manually start the service. Honestly, I don't know enough about Firebird Database to know for sure, but one thing you can try is delaying the automatic start of the 3.0.2 service and see if that gets the process going automatically.

To make this change, open up services.msc, find your Firebird 3.0.2 service and switch the startup type to Automatic (Delayed Start) and see if that gets this service working automatically. Here's an example screenshot, of what I'm talking about (but with SQL Server instead of Firebird).

enter image description here

The functionality of the delayed start is best described by CoreTech's post from the SuperUser forum:

A service marked as Automatic (Delayed Start) will start shortly after all other services designated as Automatic have been started. In my experience, this means that they are started 1-2 minutes after the computer boots.

The setting is most useful in lessening the "mad rush" for resources when a machine boots.

Note that when you have 20 services all being started at the same time, each will start up slower as it competes with the others for slices of the machine's precious resources (CPU/RAM/Disk/Network). That is, each service takes longer to become available!

If you have a few services that are critical, then you may want to set those few to Automatic and set as many of the others as you can to Automatic (Delayed Start). This will ensure that the critical services get the most resources early and become available sooner, while the non-critical services start a bit later (which by definition is ok).

No guarantees this works for you, but my fingers are crossed it does.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.