1

I had an urgent issue to solve in admin DB

I stopped all config servers, and made changes in the primary one. After restarting all other servers - balancer working only on the server where I did changes, the other two have:

balancer: Currently enabled: yes Currently running: no

Also rs.status() returns:

configsvr> rs.status()
{
        "info" : "configsvr",
        "ok" : 0,
        "errmsg" : "not running with --replSet",
        "code" : 76
}

Need some help to fix it Should I restart all config servers with some options, or need to build replication from the beginning?

  • See this answer: stackoverflow.com/questions/24557352/… – SqlWorldWide Sep 15 '17 at 12:03
  • @SqlWorldWide Hi, thanks for the answer I checked that topic, but seems I had different issue Results of ps -ef on all the servers are the same: ps -ef | grep mongo mongod 6328 1 3 Sep11 ? 03:02:29 /usr/bin/mongod -f /etc/mongodb.conf All the servers running exactly mongod with same options Or the problem is still the same as on the topic you gave? Thanks – Duiz Sep 15 '17 at 12:08
0

First: balancer is running ONLY at config server replica sets PRIMARY, never on SECONDARY.

Second: (as) your error message says that, that node where you gave rs.statatus() command is not started in replica set mode, more like maintenance mode. i.e. started without --replSet or replication.replSetName config parameter and maybe also without "sharding.clusterRole: configsvr" parameter.

You can check what where starting parameters, by just reading mongod.log file. There is (at startup) list of parameters what that mongod used when it was started.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.