I have installed Oracle 11g on my Windows 10 machine. I followed all preinstallation requirements.

When trying to log in to the Enterprise manager via this link:


I get the error:

Internal Error has occurred. Check the log file for details.

I have found log files and it looks like this is the relevant entry:

2017-09-17 07:36:53,631 [MetricCollector:HOMETAB_THREAD600:60] ERROR rt.DbMetricCollectorTarget _getAllData.344 - java.lang.NullPointerException
    at oracle.sysman.emSDK.emd.comm.EMDClient.getURL(EMDClient.java:1570)
    at oracle.sysman.emSDK.emd.comm.EMDClient.getConnection(EMDClient.java:1266)
    at oracle.sysman.emSDK.emd.comm.EMDClient.getConnection(EMDClient.java:1242)
    at oracle.sysman.emSDK.emd.comm.EMDClient.getResponseForRequest(EMDClient.java:1689)
    at oracle.sysman.emSDK.emd.comm.EMDClient.getMetrics(EMDClient.java:981)
    at oracle.sysman.emo.perf.metric.rt.DbHomeTab._getAllData(DbHomeTab.java:340)
    at oracle.sysman.emo.perf.metric.rt.DbHomeTab.getData(DbHomeTab.java:154)
    at oracle.sysman.emo.perf.metric.eng.MetricCached.collectCachedData(MetricCached.java:416)
    at oracle.sysman.emo.perf.metric.eng.MetricCollectorThread._collectCachedData(MetricCollectorThread.java:605)
    at oracle.sysman.emo.perf.metric.eng.MetricCollectorThread.run(MetricCollectorThread.java:325)
    at java.lang.Thread.run(Thread.java:595)

I have tried to set the unique name in environment variables, I thought maybe Java was the problem so I updated my JDK to 8. I am still getting the same error, and my SQL Plus will not open, as soon as I put in the correct credentials it closes. Also I have configured a Listener and tested, test was successful.

Please help.

1 Answer 1


I managed to fix the issue, turns out it was a time zone issue. The DB time zone and computer time zone were different. Thus the DB Console would not start and was giving the error "EM daemon is not running". I fixed it by following instructions here.

Also note before I did that I completely uninstalled Oracle and reinstalled it. There were some issues on that install that were causing SQL not to run. But the above is what fixed the Internal Error I was getting as I got it again even after the fresh install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.