3

I've recently installed Cumulative Update 6 for SQL Server 2014 SP2. I installed it on the passive node of a 2 node cluster. To install the patches I paused the role in cluster manager and ran the setup from command line with:

/SkipRules=Cluster_IsOnlineIfClustered /action=patch

I now need to uninstall CU6 as we've come across some issues we need to resolve. However, I am unable to uninstall the patch as I cannot get past the rule checks. If I run the same command to start setup the UI does not give me the uninstall/maintenance options.

Is there anyway to skip rules to uninstall a patch, or am I going to have to remove this node from the cluster before I can proceed?

  • It's not getting to the rule check. It has the small "extracting files" window, once that has completed it opens the UAC "Do you want the following program to make changes to this computer" window. When I click yes on that UAC window it closes down and then that's it, I'm back to the desktop. There are no windows or processes related it, I have waited several minutes a few times to no avail. The machine has also been restarted twice. If I run it from "Programs and Features" > "View Installed Updates" then I can get to the rule check for the uninstall but it fails on the clustering one. – pix1985 Sep 27 '17 at 11:07
3

With confirmation from Pix(from Chat) the correct way to remove cumulative update is to use /RemovePatch instead of using /uninstall. The way to remove updates is documented in Installing Updates from Command Prompt.

The script would be

"sqlserver2014-kb4032541-x86_080a5c3a38b721a9587c2072375921161896e19d.exe" /qs /Action=RemovePatch /InstanceName=InstanceName /SkipRules=Cluster_IsOnlineIfClustered
  • 2
    Thanks for your help. Also worth adding here in case anybody finds this thread at a later date that i could only get the SKIPRULES to work by using the quiet installer /qs, without /qs the skiprules were ignored. – pix1985 Sep 27 '17 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.