1

I had an SSRS service account password expire. This is on an Azure Windows server.

I've tried the following:

  • Updating the password caused "The report server can’t access or use the encryption key"
  • Attempting to delete the key via all the normal methods fails.
  • Manually deleting the key (keys table) doesn't give me an option to re-create a new one.

The only solution I can think of at this point is un-installing and reinstalling SSRS.

Is there a better way, or is this approach even likely to work?

0

Ended up not trying the uninstall/reinstall of SSRS.

Here's what got me working:

  • Stop SSRS service
  • detach reporting service databases
  • restart SSRS -- it complains about missing DBs
  • stop SSRS
  • reattach
  • restart SSRS
  • Using SSRS configuration wizard, re-point SSRS to its databases
  • Now I was able to delete the encryption keys

This is obviously a hack solution and fails to identify what went wrong in the first place, but it worked

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.