0

Here are four database servers. Database A is in an availability group. Database B is not - an instance exists on each server. On all but one of the servers, I am able to right-click on database B in SQL Server Management Studio and view its properties. On server 2, I get an error message that "the target database ('A') is in an availability group". This is true, but I'm not trying to access that database.

How can I view the properties of the instance of database B on server 2?

To re-iterate: I right-click on database B and select "Properties", and it tells me database A is in an availability group.

I'm logging into SSMS with Windows Authentication. I changed the connection details so my default DB is master, just in case that was the issue (it wasn't).

If it makes a difference, in the availability group for database A, this is the server that has a synchronized copy with automatic fail-over turned on.

8
  • 2
    What data are you attempting to view or change? Oct 16, 2017 at 23:48
  • Attempting to view whether or not Encryption is enabled (Properties/Options/State/Encryption Enabled). Oct 16, 2017 at 23:52
  • 3
    what happens when you open a new command window and execute 'use B' where B is the database name of database B? Does it change your context to B? What is the output of sys.databases for database B, does it show the database as online? Can you verify that there is no group_database_id in sys.databases for database B? Oct 16, 2017 at 23:56
  • 2
    I'm not sure if this is urgent or not but you can always view that info right away if you're firefighting by: SELECT [DBname], is_encrypted FROM sys.databases Sean's question leads you closer to the total solution to answer your question. Oct 16, 2017 at 23:57
  • 1
    Close SSMS, open it up again and connect only to that instance. Can you bring up the properties now? Can you add a screenshot of the issue (after closing/opening if it still fails)? Please post of the version of SSMS. Oct 17, 2017 at 1:35

1 Answer 1

0

Closing and re-starting SQL Server Management Studio fixed the problem.

Thanks to @SeanGallardy-Microsoft.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.