4

Attempting to install SQL 2016 with the latest SP and CU.

Running the following (from the directory with the Install exe):

setup.exe /Action= InstallFailoverCluster /UpdateEnabled=TRUE /UpdateSource= "D:\Software\SQLServer2016_Updates"

The GUI starts and the Product Updates step is shown but nothing is displayed.

Note that when attempting to do this as a standalone install ie Action=Install, the SP and CU are shown in the GUI.

Any thoughts (short of creating a full config file)?

  • You have "fancy quotes" around the UpdateSource path--if that was a straight copy/paste from the command you are running then that might be the problem. – Tony Hinkle Oct 20 '17 at 12:54
  • ...er, I meant “fancy quotes.” – Tony Hinkle Oct 20 '17 at 12:55
  • Ha, yes, good spot - though thankfully they didn't make it to the command line (deleted and replaced)- so unfortunately, that's not the issue. – Some Guy Oct 20 '17 at 13:09
  • Looks like it might be a bug as I'm seeing lots of blog posts from over the years using the same switches. If you have a MS support agreement you might open an incident--they should be able to repro it easily. Wish I had test servers that I could use to repro it... – Tony Hinkle Oct 20 '17 at 13:39
  • Thanks Tony - a bug was my thought as standalone finds them fine. – Some Guy Oct 20 '17 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.