-2

I am trying to install my SQL server. I have been doing this for more than a month. However, I get an error along the line of installation that says MySQLServer Setup Wizard ended prematurely because of an error. This error is not specified.

I have shutdown all services to no avail. I have googled to see if I can get solution to the cause of this error also to no avail. No information available on Google on how this can be solved. This seems to me like a bug and there is no information on how to navigate around this on the MySQL server. Also there is no way to report it.

Has anyone experienced this same problem and solved it. If so can you please assist on how this was solved. This will be greatly appreciated.

migrated from stackoverflow.com Oct 23 '17 at 6:46

This question came from our site for professional and enthusiast programmers.

  • Welcome to Stackexchange!. Which version of MySQL are you trying to install? Did you try to install MySQL installer from command line. Please share more information on this issue. – rathishDBA Oct 23 '17 at 7:15
  • Windows? I'd go for an OS reinstall and try again on a clean system! Shooting in the dark here - corruption? Normally a Windows install is a doodle! If you're any good at C/C++, you could try to compile from source - might get more meaningful errors that way? – Vérace Oct 23 '17 at 8:06
  • I am trying to install version 5.7.191. I have also tried to install 5.6.36 and bot of them are giving the same problem. – olammy Oct 23 '17 at 11:15
  • have you tried to check windows event log, to see error message – Ahmad Abuhasna Oct 23 '17 at 11:44
0

I would start with a clean install. Since you've tried to install 2 different versions, who knows what files are present and what are not. Wipe your drives, reinstall the OS, check the MySQL 5.7.19 documentation for what patches/updates you need, install only those. Then reinstall MySQL fresh. If you can pipe the log output elsewhere so you can have it available or even on a screen during the install that might help you troubleshoot should the problem crop up again.

  • I do not think the problem is with my OS. It appears that the is with Oracle and the sad part of that this is yet to be picked up by them... – olammy Oct 24 '17 at 5:45
  • You probably mean 5.7.19. What OS? – Rick James Oct 25 '17 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.