1

I'm trying to connect to SQL Server 2012 via DAC using Management Studio. I type admin: before my server name, yet I keep getting the same error:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The remote computer refused the network connection.) (Microsoft SQL Server, Error: 1225)

What I've checked:

  • I can login with no problems when using regular connection(non DAC)
  • I can also login when forcing tcp: in connection string
  • user is a sysadmin (sa)
  • I am logging in from a local server (physical sql machine)
  • SQL Server browser is enabled
  • Remote connections are enabled and firewall was disabled
  • TcpDynamicPorts in regedit was set to 59036
  • I've executed this:

    exec sp_configure 'show advanced options', 1  
    RECONFIGURE WITH OVERRIDE  
    exec sp_configure 'remote admin connections', 1  
    RECONFIGURE WITH OVERRIDE  
    

So far, nothing has helped me.

1

TcpDynamicPorts in regedit was set to 59036

Your instance is named and is configured to use dynamic ports. The default instance is listening on 1433 for all the connections and on 1434 for DAC, your port for DAC is still unknown but you can find it in error log:

xp_readerrorlog 0,1,N'Dedicated admin connection'

Then you need to check that it's open in your firewall and you can connect specifying directly this port:

myPCname,port
0

�G�Ӛ�{֪4s�����=��G�*ѥbl��[a�z�ƈʛ�п����^ߺ�s[F˺�f#.'m �%h�w��J=�@�0���Y�f ��EO���� �~�z�W9��Lzm:�=0�� ��� pi����Rƹ����0�C����9L]v6��L�,˓9c��֯�f�f(�j)o�Sz�,�N�.W�v| ̗͌�-C?G���X*jE!��酑;�5�Fh�-2s� g�l��Ka�>�RSh ���%-��XEy�1~� � �2��o����A�3%g���,u��|>?�/���6��P���yn�a@*CY](àF�@O�bIq� ����jL�mM*��My��L:T2�֌9^ �J(C�2QL��

New contributor
aliksav999 Alnzi is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.