1

while Installing oracle 11gr2 on oracle Linux 7. The prerequisite condition to test whether the OS kernel parameter "semmni" is failed with below error.

Please find the screenshot of it.enter image description here

Below is the kernel parameters which are configured in the etc/sysctl.conf file.

fs.aio-max-nr = 1048576    
fs.file-max = 6815744    
kernel.shmall = 2097152    
kernel.shmmax = 2147483648     
kernel.shmmni = 4096
#semaphores: semmsl, semmns, semopm, semmni
kernel.sem = 250 256000 100 1024    
net.ipv4.ip_local_port_range = 9000 65500    
net.core.rmem_default=262144    
net.core.rmem_max=4194304   
net.core.wmem_default=262144
net.core.wmem_max=1048586

Any idea why it is failing?

4

Having the correct value in sysctl.conf does not mean that is the current setting in effect system-wide.

You can check the current value in effect with:

sysctl -a | grep "kernel.sem"

If it differs from the one in the file configured, you need to actualize it with

sysctl -p

Or it will happen on the next reboot automatically.

  • Please find the output.[root@oracle ~]# sysctl -a | grep "kernel.sem" kernel.sem = 250 32000 256 256 kernel.sem_next_id = -1 sysctl: reading key "net.ipv6.conf.all.stable_secret" sysctl: reading key "net.ipv6.conf.default.stable_secret" sysctl: reading key "net.ipv6.conf.ens33.stable_secret" sysctl: reading key "net.ipv6.conf.lo.stable_secret" sysctl: reading key "net.ipv6.conf.virbr0.stable_secret" sysctl: reading key "net.ipv6.conf.virbr0-nic.stable_secret" [root@oracle ~]# sysctl -p fs.aio-max-nr = 1048576 fs.file-max = 6815744 kernel.sem = 250 32000 256 256 – azardin Nov 8 '17 at 13:38
  • i have check both ways. still its showing the same error. – azardin Nov 8 '17 at 13:57
  • @azardin please add the command and its output to your post – miracle173 Jan 5 at 21:53
1

One point you should be aware of is that in Oracle Linux 7 (or redhat for that matter) you don't only have a sysctl.conf but a directory /etc/sysctl.d with various configuration files (depending on your setup). So you have to check if any configuration in this directory overwrites your values.

I had the issue myself, the oracle-provided package oracle-rdbms-server-12cR1-preinstall.x86_64 was loaded and applied before other packages where loaded.

So you have to keep an eye on this directory, especially checking for the load order (they use init like S$NUMBER start ordering) and double setting of the same parameter.

  • I could see the error in the log:The value for semmni in response file is not greater than value of semmni for current session. Hence not changing it. The value for semmni in response file is not greater than value for semmni in /etc/sysctl.conf file. Hence not changing it. – azardin Nov 8 '17 at 8:31
  • According to this answer the error looks like a bug in the fixup script/installer. So if you are sure that your kernel parameters are OK go ahead and ignore the error. By the way, is there a requirement to actually use 11.2.0.4 and not a 12c version? You should also check if 11.2.0.4 is supported with OL 7. – jmk Nov 8 '17 at 20:01
  • Thanks for the response jmk. I'm sure that kernel parameters are correct. I need to install 11.2.0.4 version.so, that i can also learn the upgrading the database.It is compatible with OEL 7 OS. – azardin Nov 10 '17 at 8:32
  • Then go ahead, ignore the issue and upgrade your database – jmk Nov 10 '17 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.