1

mongoDB version: 3.4.2 os: win10 Question: Cannot start mongoDB due to .wt file corruption When reset mongoDB database path, cmd give the error as in picture Any hint would be appreciated, thanksenter image description here

  • How you are starting the "mongod" server? And what is your installation location of mongodb "BIN" directory? – Md Haidar Ali Khan Nov 6 '17 at 4:57
  • I open an cmd window under this path 'E:\Work_App\MongoDB\bin' and my installation of mongodb 'BIN' directory is 'E:\Work_App\MongoDB'. This step is aimed to reset the mongodb's db path to recover the mongodb to restart again(which normally works but this time fails). – Lizhen Nov 6 '17 at 5:06
  • Could you update the "BIN" folder (.exe) files like such as (mongod.exe (For server) & mongo (mongo shell) is there or not. – Md Haidar Ali Khan Nov 6 '17 at 5:11
  • Are you sure this is your installation path of MongoDB "E:\Work_App_MongoDB\bin"(mongod server path). By default mongodb installation path is "C:\Program Files\MongoDB\Server\3.4\bin". AS I am able to see from your screen shot no "server" folder is there.May be from wrong location you are trying to start the "mongod" server. – Md Haidar Ali Khan Nov 6 '17 at 5:16
  • Yes, I install my mongodb in the above path ,not in C:\Program Files\MongoDB\Server\3.4\bin. and my mongo and mongodb is in the path. Do you mean I need to update my mongo.exe and mongod.exe to the lastest version? thanks a lot – Lizhen Nov 6 '17 at 5:22
0

@Lizhen, may be Wiredtiger does unclean shutdown. Just go to 'E:\Work_App\MongoDB\bin' and type in command prompt like

Then run the query in command prompt “mongod --dbpath /data/db –repair”

Suppose that i have installed MongoDB in C:\Program Files\MongoDB\Server\3.2\bin then the query statement will be like that

C:\Program Files\MongoDB\Server\3.2\bin>mongod --dbpath /data/db --repair

As you already said your MongoDB installation path is E:\Work_App_MongoDB\bin. So in your place it would be

E:\Work_App_MongoDB\bin>mongod --dbpath /data/db –repair 

I hope so that it will be help out to you.

|improve this answer|||||
  • Thanks, I tried this method,but still not solve my problem. It seems to be collection corruption. – Lizhen Nov 7 '17 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.