6

I just upgraded from MongoDB 3.2 to 3.4.1.

/etc/mongod.conf had a multiple BindIP:

bindIp: [127.0.0.1,192.168.20.1]

This is not working anymore. I get this error :

Scalar option 'net.bindIp' must be a single value

According to the documentation, It must be correct : https://docs.mongodb.com/manual/reference/configuration-options/#net.bindIP

Any idea ?

1 Answer 1

7

Remove []. so solution is: bindIp: 127.0.0.1,192.168.20.1 and remember, no space characters anywhere in that string.

1
  • 1
    I tried but there was a space between the ips... Thanks !
    – hotips
    Nov 22, 2017 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.