0

MySQL in XAMPP isn't starting after I installed MySQL Server. MySQL Server is using port 3306, so I've changed in xampp\mysql\bin\my.ini:

[client] 
port            = 3360
socket          = "C:/xampp/mysql/mysql.sock"

[mysqld]
port= 3360

And in xampp\php\php.ini:

mysqli.default_port=3360
mysql.default_port=3360

Also in XAMPP Control Panel -> Config -> Service and Port Settings -> MySQL changed Main Port to 3360.

After all these changes it still isn't working.

Nestat is showing 3306 is used by mysqld.exe, so I think XAMPP MySQL should work correctly on 3360.

Also I've tried to switch off MySQL server, didn't help to.

Error:

Error: MySQL shutdown unexpectedly

Logs:

2017-11-24 17:08:48 2498 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2017-11-24 17:08:48 9368 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2017-11-24 17:08:48 9368 [Note] InnoDB: The InnoDB memory heap is disabled
2017-11-24 17:08:48 9368 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2017-11-24 17:08:48 9368 [Note] InnoDB: Memory barrier is not used
2017-11-24 17:08:48 9368 [Note] InnoDB: Compressed tables use zlib 1.2.3
2017-11-24 17:08:48 9368 [Note] InnoDB: Using generic crc32 instructions
2017-11-24 17:08:48 9368 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2017-11-24 17:08:48 9368 [Note] InnoDB: Completed initialization of buffer pool
2017-11-24 17:08:48 9368 [Note] InnoDB: Restoring page 0 of tablespace 0
2017-11-24 17:08:48 9368 [Warning] InnoDB: Doublewrite does not have page_no=0 of space: 0
2017-11-24 17:08:48 9368 [ERROR] InnoDB: space header page consists of zero bytes in data file C:\xampp\mysql\data\ibdata1
2017-11-24 17:08:48 9368 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
2017-11-24 17:08:48 9368 [ERROR] Plugin 'InnoDB' init function returned error.
2017-11-24 17:08:48 9368 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2017-11-24 17:08:48 9368 [Note] Plugin 'FEEDBACK' is disabled.
2017-11-24 17:08:48 9368 [ERROR] Unknown/unsupported storage engine: InnoDB
2017-11-24 17:08:48 9368 [ERROR] Aborting

Someone, please help.

2

i suspect this

2017-11-24 17:08:48 9368 [ERROR] Unknown/unsupported storage engine: InnoDB

is the problem.

Try deleting

ib_logfile0 and ib_logfile1 from your MySQL directory

  • First time solved, but getting same error after restart. – 151291 Apr 13 '18 at 6:53
1

In my case It fixed by:

  1. Starting xampp-control.exe as administrator.

  2. Start Apache and MySQL Services.

Everything worked fine.

So I set appropriate folder permissions on c:\xampp helped to run the services normally.

In my case I gave full control to current windows user to the xampp folder.

I guess when I first installed the xampp stack, I ran the installer as administrator and maybe this is the cause of insufficient permissions when the program runs under non-elevated user scenarios.

I also didn't turn off Windows User Account Control and maybe it could be another workaround to turn the UAC off.

0

You can completely reinstall XAMPP or just install it in another directory and then copy the folder xampp\mysql\data to the old installation. It helped me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy