0

When I try to add a subscription to a transactional publication I get an error. The error is:

Creating Subscription(s)...

- Creating subscription for 'bejonlsql07\bi' (Error)
    Messages
    * SQL Server could not create a subscription for Subscriber 'bejonlsql07\bi'. (New Subscription Wizard)

    ------------------------------
    ADDITIONAL INFORMATION:

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

    ------------------------------

    'BEJONLSQL07\Bİ' is not defined as a Subscriber for 'BEJORUMSSQL01'.
    Could not update the distribution database subscription table. The subscription status could not be changed.
    The subscription could not be created.
    Changed database context to 'NAVRUMS'. (Microsoft SQL Server, Error: 20032)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=12.00.5557&EvtSrc=MSSQLServer&EvtID=20032&LinkId=20476

I already tried disabled publishing and distribution completely and setting up as new. But I still get the same error.

It has worked on this server before. I just had to disable replication for some maintenance and wanted to add it again.

I looked in all tables if there is some leftover replication info from before but I cannot find anything.

UPDATE

When i look at the linked servers it somehow adds the subscription server two times.

  • The link that you reference is taking me to this: Only $799 Save $200 on Surface Pro with Intel Core i5/128GB SSD, while supplies last. Perhaps you can find a different link that is applicable. – RLF Nov 28 '17 at 18:10
0

Replication can be tricky. You literally need to drop all of your articles, and configurations... EVERYTHING. If you perform this process via the GUI it leaves things behind, and you end up with a situation like this. This command below is the nuclear option, and should only be used if all else fails. Based on what I'm seeing this is one of those situations.

USE master;
EXEC sp_removedbreplication 'yourdatabasename';

After this is done double check to see if your database is still set to being published. If your database doesn't have a check mark then start your replication process from scratch.

enter image description here

UPDATE

I just had this exact same error occur on one of my production servers. The sp_removedbreplication command resolved my issue.     :)

  • Yesterday evening I reinstalled the SQL Server thats hosts the database that needs to be replicated and i still get the same error. I also just tried your solution and unfortunately it still doesn't work. – RobertU Dec 1 '17 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.