1

When running Mongod I get the following WARNING: The file system cache of this machine is configured to be greater than 40% of the total memory. This can lead to increased memory pressure and poor performance. This is on a windows 10 pro 64 bit machine. I have 16 gigs of ram. I have a 225 gig ssd drive c: and 2 1 terabyte drives d: and e:

I've set the virtual memory as follows:

drive     initial size       max
c:         800               1000
d:         400                800
e:         400                800

it says space available is 134538 MB

The mogod reference says the following:

Check the Windows file system cache limit. Having a too high or unbound 
upper limit can impact performance. Specifically, having a file system cache 
that uses 40% or more of the total memory can lead to increased memory 
pressure and poor performance. Use SetSystemFileCacheSize to limit the 
amount of memory that the file system cache can use.

Could someone provide directions on how to do that? The answer from @Md Haidar Ali Khan does not work

  • Mongodb 3.6 community – DCR Dec 8 '17 at 18:03
  • ,Is this a page file issue?? . Definitely No. It's just a notification message come from 'mongod' server. which has implemented in MongoDB version 3.6. – Md Haidar Ali Khan Dec 8 '17 at 18:09
1

I found a free tool that will set SetSystemFileCacheSize here with 16 gigs of RAM I set it to 1024 4096 and the mongod warning went away

  • Even that is just MongoDB 3.6 version implemented notification. That will not impact for your MongoDB performance degradation. – Md Haidar Ali Khan Dec 9 '17 at 11:24
0

@DCR, As MongoDB 3.6 officialy released as on dated 5th December 2017. For Testing environment i have deployed MongoDB 3.6 in my environment. There is two new things i got in MongoDB 3.6 , which i have noticed. When we are starting the mongod server

1)The file system cache of this machine is configured to be greater than 40% of the total memory

2)Starting in MongoDB 3.6, mongod bind to localhost (127.0.0.1) by default. See Default Bind to Localhost.

Even in my Environment the test system setup configuration is

1)windows 10 enterprise with 64-bit

2) HDD is 500 GB

3)MongoDB version is 3.6

4) RAM is 4 GB

Note : The --wiredTigerCacheSizeGB limits the size of the WiredTiger internal cache. The operating system will use the available free memory for filesystem cache, which allows the compressed MongoDB data files to stay in memory. In addition, the operating system will use any free RAM to buffer file system blocks and file system cache.

To accommodate the additional consumers of RAM, you may have to decrease WiredTiger internal cache size.

After Edit

@DCR, Even in my environment i am also getting the same message after running the mongod server. It's nothing but a cache warning message which comes from wiredTiger storage engine. I am also uploading the screen shot below

enter image description here

As per MongoDB jira Blog Add warning about Windows SystemFileCacheSize for WiredTiger Some MongoDB users on Windows have switched to enabling direct_io because the file system cache on Windows is greedy by default and can lead to content in allocated memory getting swapped out - which leads to terrible performance. Windows provides the SetSystemFileCacheSize API that allows limiting the amount of memory that can be used by the file system cache. The setting is global across the computer. We could add code into MongoDB that calls the API, and limits the amount of memory the file system cache can use to a percentage of available memory. The call should only be done for storage engines that have a cache management layer. MMAP relies on the file system cache using all available memory - limiting how much memory is available would hurt MMAP users.

As starting in MongoDB 3.0, the WiredTiger storage engine is available in the 64-bit builds. Changed in version 3.2: The WiredTiger storage engine is the default storage engine starting in MongoDB 3.2.

For further your ref Here , Here and WiredTiger storage engine

  • Could you suggest default parameters to use with this option ? – DCR Dec 8 '17 at 18:56
  • I used the following command: mongod -wiredTigerCacheSizeGB=10 --dbpath=c:\mongoDATA\db\ and got the same result. So that doesn't seem to be the issue either. Is there something use you can suggest? – DCR Dec 8 '17 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.