0

I installed Oracle database 10g as an administrator on a windows 10 machine, it worked fine, but when i try to connect sys as sysdba it gives me the error:

ORA-01031: insufficient privileges

I checked sqlnet.ora file and if SQLNET.AUTHENTICATION_SERVICES is NTS and it is:

SQLNET.AUTHENTICATION_SERVICES= (NTS)
NAMES.DIRECTORY_PATH= (TNSNAMES, EZCONNECT)

I added the user to the ORA_DBA group and i checked with:

c:\Oracle>echo %username%

and

c:\Oracle>NET LOCALGROUP ORA_DBA

and the user is in the group.

I don't know what else i should do, anything will be helpful.

-1

Are you connecting as

 sys as sysdba

or

 / as sysdba

?

If you are using the first option, is it prompting you for a password, and are you entering the password for the user? Did you create a local Windows user account as the user, not the user id used to install the software? Oracle recommends a user with administrators group install the software, and a local Windows user be defined for the sys and system accounts.

  • i am using "sys as sysdba" and it is not asking me for a password, and i didn't create any local windows user. I installed the software as an administrator that's all, it works in other machines (windows server 2012) i don't know about this one, the only difference other than the OS is the oracle folder is in D partition. – zenami Dec 14 '17 at 15:59
  • Hmmmm. Sorry; not sure what else to check. It should not matter that Oracle is on d: drive; I would just check the registry key in regedit HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\KEY_* where * is your oracle home registry folder name. – Mark Stewart Dec 14 '17 at 16:51
  • check for what in the registry? – zenami Dec 14 '17 at 18:18
  • Check if ORACLE_HOME is set to what you expect, etc. I'm struggling through some similar issues so sorry I cannot offer more details. – Mark Stewart Dec 16 '17 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.