1

please, can you clarify this? My configuration is RAC 12c on ASM on SLES 11 SP 4 on SystemZ.

The nodes rac11 and rac12 are the server nodes of the primary database, named "primdb", uniq_name is "primdb". The instance names are prim1 and prim2 correspondingly.

The nodes rac21 and rac22 are nodes of the standby database named "primdb", uniq name is "stdbydb". The instance names are stdby1 and stdby2 correspondingly.

So, I'm trying to create physical standby using RMAN active duplication.

After configuring such parameters as log_archive_dest, dump_dest, and so on I copied password file to the standby server and changed init-file. I added static entry to the listener on rac21 (not SCAN-address) with service name of the stdby1 instance and was able to connect to "nomount" database as SYS from any of my servers.

$>su - oracle
$> . oraenv
    ORACLE_SID = [oracle] ? stdby1
    ORACLE_HOME = [/home/oracle] ? /u01/app/oracle_home
    The Oracle base has been set to /u01/app/oracle_base
$>sqlplus / as sysdba
SQL>startup nomount pfile='/tmp/initstdby1.ora'

after that i perform the following:

$> rman target sys/q1@primdb auxiliary sys/q1@stdby1

connected to target database: PRIMDB (DBID=636407725)
connected to auxiliary database: PRIMDB (not mounted)

$>duplicate target database for standby from active database nofilenamecheck;

And on the step of executing memory script (sorry, i can't paste all RMAN output here) a wild error appears

RMAN-00571: =========================================================== RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-00571: =========================================================== RMAN-00554: initialization of internal recovery manager package failed RMAN-04006: error from auxiliary database: ORA-00600: internal error code, arguments: [kzsrsea_ext], [], [], [], [], [], [], [], [], [], [], [] ------------------------------------------->

After that i'm not able to connect to this nomount database using sql*Net, the same error ORA-600 appears . The only way to connect to this database instance is to connect locally

sqlplus / as sysdba

And the interesting moment - if i copy the passwordfile again from the primary database to standby, i can connect to this standby database instance.

So i think, that RMAN changes my passwordfile on the standby server. I searched for the same error on MOS (Doc ID:1136834.1), but they suggest to use backups as the workaround, which is not suitable for me.

Any help would be much appreciated..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.