0

I'm trying to install SQL using a config.ini file but it doesn't seem to accept the parameters set in the file.

For example, at the top of my file I have:

;SQL Server 2017 Configuration File
[OPTIONS]

IACCEPTSQLSERVERLICENSETERMS="True"

I run this:

C:\Temp\sql-server-2017.exe /ConfigurationFile="C:\Temp\sql-config.ini"

And yet, it will open the install window and ask me to "Accept Terms"

Another example, I have quiet simple set to true:

; Setup will not display any user interface. 

QUIET="False"

; Setup will display progress only, without any user interaction. 

QUIETSIMPLE="True"

But when I run: C:\Temp\sql-server-2017.exe /ConfigurationFile=C:\Temp\sql-config.ini /IACCEPTSQLSERVERLICENSETERMS /MediaPath=C:\Temp\SQL

I get this in the summary and error:

enter image description here

enter image description here

  • How sure are you about your config file? Your screenshot shows Quiet and QuietSimple both = true which would explain your last error. Installing SQL 2014 we use /IAcceptSQLServerLicenseTerms and /ConfigurationFile successfully. Maybe 2017 is different? – Greg Dec 19 '17 at 0:37
  • So yea the summary shows that but the actually ini file is set to quiet=false and quiestsimple=true that's why I'm confused – Batman Dec 19 '17 at 0:38
  • What happens when you run C:\Temp\sql-server-2017.exe /ConfigurationFile=C:\Temp\sql-config.ini /IACCEPTSQLSERVERLICENSETERMS /MediaPath=C:\Temp\SQL /Q ? From BOL - Unattended installations (using the /Q or /QS parameters) must include the /IACCEPTSQLSERVERLICENSETERMS parameter. – Kin Shah Dec 19 '17 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.