2

I'm installing XAMPP on my machine. I'm following Derek Banas youtube tutorial, and I also tried myself, but I'm constantly running into the same issues.

I have changed my Apache ports to 1234 (main), and 8181 (SSL) and MySQL ports to (3307). Apache runs fine, but when I run MySQL from the XAMPP control panel it get this error log.

23:11:36 [mysql] Error: MySQL shutdown unexpectedly.

23:11:36 [mysql] This may be due to a blocked port, missing dependencies,

23:11:36 [mysql] improper privileges, a crash, or a shutdown by another method.

23:11:36 [mysql] Press the Logs button to view error logs and check

23:11:36 [mysql] the Windows Event Viewer for more clues

23:11:36 [mysql] If you need more help, copy and post this

23:11:36 [mysql] entire log window on the forums.

I have also deleted files from the MySQL folder in the xampp folder recommended in a previous stack overflow question https://stackoverflow.com/a/18162264/9182716

Also when trying to navigate to localhost phpmyadmin I'm prompted with this warning screen.

https://imgur.com/a/7iagc

6
  • please update your question with your my.cnf file contents, mysql version number. – Will B. Jan 6 '18 at 23:35
  • Did you make the necessary firewall exceptions in your windows firewall? – Will B. Jan 6 '18 at 23:38
  • @fyrye MySQL version is 5.7. I can't find the cnf file. I wasn't prompted to make a firewall change? – Andremac96 Jan 7 '18 at 0:06
  • In windows the default paths in order are C:\Windows\my.ini C:\Windows\my.cnf C:\my.ini C:\my.cnf C:\xampp\mysql\my.ini C:\xampp\mysql\my.cnf C:\xampp\mysql\bin\my.ini C:\xampp\mysql\bin\my.cnf – Will B. Jan 7 '18 at 0:15
  • 1
    If phpmyadmin says access denied, then a mysql is running on your computer. You may have multiple mysql instances installed. But this question has nothing to do with programming, this is purely an admin question. – Shadow Jan 7 '18 at 0:31
0

I had this problem too. If changing MySQL port doesn't solve the issue, which was my case. Simply copy the files in xampp/mysql/backup to xampp/mysql/data. Replace any conflicting files and leave the rest.

Then restart Apache and MySQL from the Xampp control panel.

This should solve the problem.

-1

I uninstalled and re-installed XAMPP and then went to msconfig and Reduced the UAC to "Never Notify me " and then went back and refreshed mysql on XAMPP. It worked!

1
  • You can't just disable User Account Control to fix a problem on your Xamp configuration. Otherwise, I think the problem was fixed during the reinstallation not because you turned off UAC. – Jesus Uzcanga Sep 30 '19 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.