0

i wanted to increase the value of gcache.size on my 3 nodes of the mariadb galera cluster (galera v25.3.22(r3764), mariadb Ver 15.1 Distrib 10.0.33 - MariaDB, for Linux (x86_64) using readline 5.1), from the standard 128MB to 1G.

I have sufficient space on my disk.

I shutdown all 3 nodes, change the parameter in the my.cnf:

wsrep_provider_options="gcache.size=1G" restart the nodes, but the size stays same (on disk as in the wsrep_provider_options).

is this a bug?

I can for example change these 2 parameters without problem:

wsrep_provider_options="gcache.recover=yes"

wsrep_provider_options="gcache.page_size=1G" but the gcache.size doesnt increase

  • Don't you mean size instead of page_size? – Rick James Jan 8 '18 at 13:15
  • yes, size, but if I leave out the other parameters (page_size and recover=yes), it works. why is that gcache.recover=yes for then? you can use it in combination with gcache.size? – stoffel Jan 8 '18 at 14:19
0

Make sure that your configuration file only has one instance of the wsrep_provider_options otherwise the last instance is used.

http://galeracluster.com/documentation-webpages/galeraparameters.html

Settings for wsrep_provider_options should be defined as a semicolon-separated key value pair list, such as key1 = value1; key2 = value2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.