0

We have a setup with a data mining slave with a lot of replicate-ignore-table= for tables that aren't needed. Now the developers have requested to populate a table that is currently ignored. How do I go about populating it so that the replication can be started again at the correct point.

I want to avoid locking the table on the master instance as that would lead to application downtime.

We are not yet using GTID.

I have access to MySQL Enterprise Backup if that helps.

0

Do these two steps while nothing is being added to the table:

  • Manually copy the table to the Slave(s) (even if empty -- need table definition).
  • Remove the replacate-ignore setting.
  • Probably should have added that the "while nothing is being added to the table" is not a viable option as that would lead to application downtime. – antonagestam Jan 10 '18 at 10:31
  • @antonagestam - See if Percona's XtraBackup can pull a stunt. – Rick James Jan 10 '18 at 15:49
0

Just remove the replicate-ignore TABLE NAME tag from the my.cnf and restart the service the table will populate on the slave automatically ,This should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.