0

After a dump import the disks got full and as to try to fix it I just removed the corresponding directory within /var/lib/mysql and now the database doesn't load anymore.

I have some other databases that were running on this server and now none of them works now. All what I want is to load the mysql again to recover the other databases.

I tried to start the database with innodb_force_recovery = 6 and I it didn't work.

May anyone give a clue to solve this problem?

  • The information about each table is found both in the ibdata1 file and in the directory that you deleted. That is, your attempt to free space is doomed to failure. – Rick James Jan 10 '18 at 0:59
1

I would like to share how I have fixed this issue.

I just created a fresh mysql dir with mysql_install_db and then copied all other database directory into it and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.