2

My SQL Server 2014 Configuration Manager is empty except for SQL Server Integration Services 12.0. It should show a bunch of other services, Like SQL Server, SQL Browser, SQL Agent, etc. I found a related question, and did the solution listed there. I successfully changed the value, but it didn't fix my issue. Here's the question/solution I tried:

https://dba.stackexchange.com/a/5208/125955

I tried installing another instance of SQL Server but those services do not show up either. The Database Engine is for sure installed, I can connect to the server and do stuff via SQL Server Management Studio.

5
  • 2
    Are you sure the Configuration Manager is the newest one on the system, and that the services you expect to show up aren't a higher version? Older config managers aren't going to show 2014+ services, and 2014 config manager won't show 2016+. Jan 17, 2018 at 22:24
  • @AaronBertrand I do have an older Configuration Manager on this PC, but I am looking at the current one in this case.
    – coinbird
    Jan 18, 2018 at 15:13
  • if you are using "SQL Server 2014" then open the configuration manager from the command line: sqlservermanager12.msc. note: make sure to run this as administrator Jan 21, 2018 at 21:37
  • @HamzaRabah Looks the same. Configuration Manager, and only shows Integration Services...
    – coinbird
    Jan 22, 2018 at 17:01
  • What do you see in Services?
    – RDFozz
    Mar 16, 2018 at 22:12

3 Answers 3

4

Start-->Run and type services.msc and check installed SQL Services. Do you see the installed SQL Server services? Please refer below articles.

These may help:

2

you could be looking at the wrong version of SQL configuration manager , if multiple versions are installed on your server.

1
  • Yes, In my case, it was due to the fact I was opening wrong Configuration Manager. I upgraded from 2019 to 2022 version but I was still clicking "SQL Server 2019 Configuration Manager", while I should click "SQL Server 2022 Configuration Manager" that was listed after.
    – Uttam
    Dec 11, 2022 at 5:36
0

Please check if the SQL Server installation is complete. The management studio might be installed, but there is no SQL server instance.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .