3

I have an Azure Windows Server in a managed Domain (AD Domain Services) running SQL Server Enterprise.

I am trying to simply deploy a local (laptop) SSIS project to the remote SSIS server. When the deployment dialog appears and I enter the IP address of the VM, I get the dreaded:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.) (Microsoft SQL Server, Error: -2146893019)

Importantly/Potentially related, I am using "Active Directory Password Authentication" and passing the credentials of a domain user (on the remote AD domain) which is an admin on the VM.

I tried also using SQL Authentication, but you cannot deploy a package using SQL Authentication (SSIS requirements).

I have searched long a wide for a solution to this, and a lot of hints point to changing a connection string, which doesn't apply to me since I'm using the VS2017 SSDT deployment wizard (no advanced options either).

0

Try this:

Open Windows CMD.EXE and type and enter the following and restart your computer:

netsh winsock reset

Reference: https://stackoverflow.com/questions/21681762/how-do-i-fix-an-error-connecting-to-sql-server-ssl-provider-error-0-the-mes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.