1

I installed a SQL Server 2014 Developer Edition on a VM, because the Express Edition is limited to just 10GB. Now I've tried to conncet to that server remotely from my VM with SSMS. But I get an error that I cannot connec:

(provider: SQL Network Interfaces, error: 28 - Server doesn't support requested protocol) (.Net SqlClient Data Provider)

On the Express Server there is an NT AUTHORITY\NETWORK SERVICE login. So my conclusion was to add NT AUTHORITY\NETWORK SERVICE to the logins, so I can access the server and databases with SSMS from a different PC, hoepfully.

I do find a NETWORK SERVICE user when searching for it. It then shows up as VM-THIS\NETWORK SERVICE. So no NT AUTHORITY.

When I try to add the VM-THIS\NETWORK SERVICE, on hitting OK, I get the following error:

Windows NT user or group 'VM-THIS\NETWORK SERVICE' not found. Check the name again. (Microsoft SQL Server, Error: 15401)

Having a look at the error code couldn't help me solving this.

So on the one side I can find the user, but adding causes an error? What am I doing wrong?

  • 1
    >>>so I can access the server and databases with SSMS from a different PC<<< Why should one add NT AUTHORITY\NETWORK SERVICE in order to..."access the server and databases with SSMS from a different PC"? SSMS passes to server YOUR credentials, not NT AUTHORITY\NETWORK SERVICE – sepupic Feb 7 '18 at 14:32
  • It was my conclusion, that I have to add the NETWORK SERVICE login to access the server on that VM from the VM I'm working on. – FredM Feb 7 '18 at 14:34
  • Possible duplicate? stackoverflow.com/questions/13238219/… the original error you're getting refers to the network protocol you're using, not the credentials. – Gareth Lyons Feb 7 '18 at 14:56
  • And that was the source of failure. Should've investigated more. – FredM Feb 7 '18 at 15:26
0

Open up SQL Server Configuration Manager on the server, go to SQL Server Network Configuration, and make sure that your instance's TCP/IP Protocol Status is Enabled or set not disabled.

0

The account will show up as just NETWORK SERVICE when you are looking at the local accounts via the UI (I recall). I'm not sure why you see one with the hostname but that would not be a system account on the local machine.

You can always just use T-SQL to add the login:

CREATE LOGIN [NT AUTHORITY\NETWORK SERVICE] FROM WINDOWS;

Then assign it whatever permissions you would like.

  • Unfortunately the T-SQL doesn't work. SSMS tells me to check the spelling. – FredM Feb 7 '18 at 14:32
  • Well it runs fine on my machines. – user507 Feb 8 '18 at 15:23
0

When accessing remote SQL Server (or share or another resource) there is no such account as "NT AUTHORITY\NETWORK SERVICE".
This only exists on the local server.

The local "NT AUTHORITY\NETWORK SERVICE" access remote resources as the machine account "DOMAIN\ServerName$"

Example:

  1. ThisWebServer access ThatSQLServer
  2. Both ThisWebServer and ThatSQLServer are in the same MYDOMAIN
  3. Any process on ThisWebServer using "NETWORK SERVICE" will access SQL Server on ThatSQLServer as "MYDOMAIN\ThisWebServer$"

Also see

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.