1

A few colleagues & I have installed the latest Visual Studio (SSDT) - BIDS.

We are unable to create packages, in Solution Explorer right clicking on SSIS Packages > New SSIS Package results in this infamous error:

TITLE: Microsoft Visual Studio

Error creating package Failed to save package file "C:\Users\userid\AppData\Local\Temp\tmp9ABC.tmp" with error 0x80040154 "Class not registered".

enter image description here

Googling this error brings up results from 2008 and it pertains to MSXML. I've tried all the solutions, install MSXML6.0, install OWC, regsvr32 the DLLs, I ran procmon and there is no hint of the problem in the trace.

I am very confident this is a different bug to the 2008 one as none of the solutions work.

One of my colleagues installed BIDS at home and it works perfectly. The work network we are in is locked down, however we all ran the install as Admins and the ISO file was > 2gig so we don't believe a component was missed during the install, but this could be wrong.

Has anyone encountered this error? Anyone got any ideas of how to troubleshoot this?

2

I've uninstalled the old version of VS2017 SSDT (15.4.xx) and download the latest SSDT 2017 (15.5.x) from Microsoft then, install it. It seems to be working now. I can create a new SSIS package. Yehey!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.