19

I'm having trouble finding answers with various Internet and Google searches for MySQL Workbench issue I'm experiencing.

I have not found any answers on how to make this work again.

Here's the MySQL Workbench error I'm having issues troubleshooting which I need help

mysql workbench failed to connect at localhost:3306 with user root ssl connection error: ssl is required but the server doesn't support it

3
  • A couple of notes: localhost is always the computer the command is running on, so I'm not certain that encryption serves much purpose. SSL requires a certificate be installed on the server in question. See if you can modify the configuration in mysqlworkbench to connect to the server without encryption/SSL.
    – RDFozz
    Mar 1, 2018 at 23:45
  • For Windows Client, if you don't have the SSL Option Required = No, after MySQL Workbench update, check @AntonioMariaSanchez answer. Dec 13, 2021 at 17:08
  • Workbench V8.0.28 is now available and fixes this issue
    – RiggsFolly
    Apr 4 at 12:43

8 Answers 8

19

Configure MySQL Workbench to not require SSL encryption

If you get the MySQL Workbench error of "SSL connection error: SSL is required but the server doesn't support it" then you likely just need to change a setting that's defined within the MySQL Connections within MySQL Workbench.

enter image description here

From the MySQL Connections screen click on the little wrench icon enter image description here to the right to bring up Manage Server Connections window.

enter image description here

From the Manage Server Connections window click on the "MySQL Connection" that is giving you this error, then from the SSL tab you will want to ensure the Use SSL field has a value of If available so it only uses SSL if it's available or else it'll connect without SSL encryption.

enter image description here

Press the Test Connection option from the bottom of the Manage Server Connections window after you make the to confirm the error goes away.


Continued Trouble

Update: Firstly, downgrading to version 8.0.26 brings back the No and If available options for the Use SSL field. They're removed in version 8.0.27. You can find older versions here of MySQL Workbench here: MySQL Product Archives

If you continue to have trouble you might set the Use SSL field to a value of No and also ensure all the SSL fields below that are blank and then test the connection again.

enter image description here

6
  • This answer will only work in some case uses. My case use was different. I was trying to use TLD SSL to connect MYSQL which is more difficult. Nov 7, 2018 at 15:19
  • 2
    I don't have Use SSl "No" here, any other solution? Oct 31, 2021 at 9:49
  • 5
    @KarimSamir Downgrading to 8.0.26 brings back the No and If available options. They're removed in 8.0.27. You can find older versions here: downloads.mysql.com/archives/workbench Nov 2, 2021 at 9:08
  • 3
    @MagnusWinter I looked over the release notes a few versions back and I didn't see anything obvious indicating they are taking those options away. Do you know if they changed this intentionally as per a previous release mentioning deprecating the function with those options? Just curious if it's a bug with version 8.0.27 or if this has been a change that's been known to be coming. And I added an update to my post per this comment, so thank you! Nov 2, 2021 at 11:38
  • 4
    why dnt they just leave the option there... sometimes things can be so annoying, PS ** thanks @ITThugNinja
    – Seabizkit
    Nov 2, 2021 at 13:49
20

At least in MySQL Workbench community edition 8.0.27 no Use SSL option is not available. You could define useSSL parameter described in previous answer, in the Advance tab:

enter image description here

6
  • 1
    This is the more easy solution to the problem on Windows Dec 13, 2021 at 17:06
  • 2
    The option useSSL=0 worked for me. Windows 11 Workbench 8.0.27
    – Gildonei
    Dec 31, 2021 at 13:51
  • 1
    Much better option than downgrading.
    – Tisch
    Dec 31, 2021 at 15:23
  • I used, but when I click in test conexion everything ok, but when I close and try to connect show me error and if edit conexion again the useSSL=0 don't appear (I use Linux Ubuntu 20.04) and workbench 8.0.27 Jan 5 at 22:11
  • On Linux, Workbench 8.0.27 does not have the option to make SSL optional.
    – bob
    Jan 6 at 7:36
17

You can bring back the old SSL options in 8.0.27:

  • Close MySQL Workbench
  • Go to you MySQL Workbench install folder (p.e. C:\Program Files\MySQL\MySQL Workbench 8.0 CE)
  • open the file modules/data/mysql_rdbms_info.xml
  • replace all occurrences of
    • >2|Require,3|Require and Verify CA,4|Require and Verify Identity
    • with >0|No,1|If available,2|Require,3|Require and Verify CA,4|Require and Verify Identity

Now you have the old options back: enter image description here

4
  • 2
    Same file in linux relies at /usr/share/mysql-workbench/modules/data/mysql_rdbms_info.xml
    – Sajjad
    Dec 16, 2021 at 16:49
  • 2
    MAC Os - Open in the Finder with Right-click in the Applications/MySQLWorkbench - Show Package contents and edit the file Resources/modules/data/mysql_rdbms_info.xml Dec 20, 2021 at 16:26
  • Worked for me on Win 10. Thank you Jan 6 at 8:54
  • This is a much better solution than downgrading to a possible unsafe older Version!
    – Tokk
    Feb 10 at 20:05
6

In workbench 8.0.27 if under the SSL tab you don't see the option No, edit file $HOME/.mysql/workbench/connections.xml, look for the connection that you want to disable ssl, and find <value type="int" key="useSSL">2</value> set it to 0, that will disable ssl for that connection.

2
  • 1
    Note that this does not seem to work on windows. When after editing ~\AppData\Roaming\MySQL\Workbench\connections.xml, when a connection is attempted, the value is changed back to a 2.
    – Andrew
    Nov 16, 2021 at 4:29
  • Sorry about Windows, I have never test it on it as I'm a Linux user, but good catch. Thanks
    – ManKino
    Nov 17, 2021 at 12:11
5

add useSSL=0 in advanced tab

add useSSL=0 in advanced tab this worked for me in win 10

1

windows10, Workbench 8.0.27
close the MySQL Workbench (important, otherwise it will overwrite the edit)
in ~\AppData\Roaming\MySQL\Workbench\connections.xml
set <value type="int" key="useSSL">0</value> and save.

DO not touch the Edit Connections for this connection, it would overwrite the 0 by a 2

1
  • this solution worked for me
    – Nasik Ahd
    Dec 28, 2021 at 8:31
1

A bug in MySQL Workbench 8.0.27. Fixed for 8.0.28 whenever that gets released. Details at link.

-1

i was facing same problem since last 3 days but i realize that if new version of workbench don't have NO/IF AVAILABLE option but we can solve it through go to ADVANCE and write on others: useSSL=0 and remain keep same.
It will solve but with attention/warning.

1
  • 1
    Hi there and welcome to the DBA.SE community. Your answer doesn't seem to add any additional solutions other than those already provided.
    – John K. N.
    Dec 13, 2021 at 10:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.