0

The problem started when a table, started not to fetch a single SELECT. It was only a SELECT * FROM table; and it started to run and never stopped. After several attempts, all of them failed, and then I tried to drop the table (it has backups), but the SAME problem happened.

My last, and failed attempt was to rename the table and then restore a backup table.

I tried to use MySQL Workbench feature to Alter Tables but, Windows error (I use Windows 7 at my job). Windows offered me to "Try to restore the program" and it indicates me it was an "Error Getting DDL Object". Then I checked the tables information, and DDL tab was empty.

So.... I don't what to do. Is there a way to change this DDL? Or maybe another way?

migrated from stackoverflow.com Mar 2 '18 at 19:32

This question came from our site for professional and enthusiast programmers.

  • I already tried to add a column too. – Cauan Martins Feb 22 '18 at 17:11
0

I discovered, after a long research, that it could be a process which wans't interrupted (somehow).

Then it was only:

show processlist;
kill [ID of the running process];

And then I was able to drop/alter that table.

0

In my case, I got the same error message with a full disk at the server side where MySQL was running. Obviously, MySQL server failed to run correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.