1

I have a test box with 4 Instances of SQL Server on it. One 2012 instance and three 2008 R2 instances.

Database mail works fine on one of the named 2008 R2 Instances but not on any of the others.

I've been going through the troubleshooting steps on Microsoft's website and everything checks out. All of the settings are correct and it's starting just fine, it just won't send an email.

The profiles are public and the logins have the appropriate permissions.

The mail log contains:

Log ID           9137
Process ID       7740
Mail Item ID     6031
Last Modified    3/5/2018 11:34:23 AM
Last Modified By sa

Message
The mail could not be sent to the recipients because of the mail server failure.
(Sending Mail using Account 1 (2018-03-05T11:34:23).
Exception Message: Could not connect to mail server.
(A non-recoverable error occurred during a database lookup).

I have tried both sending the test emails through the UI (via Send Test Email), and through my own procedures. When I look in the database mail log I see the same errors stretching back to when I built the instances. I see messages in the log file about database mail successfully starting and shutting down.

I've rebooted several times and all of the settings are exactly the same between instances. One instance works perfectly and three others don't. If it were a firewall or AV issue it would more than likely be the same for all instances.

1

I'm not sure what the actually issue here was but after dropping the account and profile and re-creating them everything worked.

Looking back, I realize that I had set it up on the first instance with the GUI, and then scripted it out and ran the script for the other instances. Why that didn't work I'm not sure.

A big thank you to everyone who tried to help me.

  • 1
    My hunch is that the GUIDS of the accounts were out of sync between SQL instances. – Shaulinator Mar 6 '18 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.