0

I am looking to connect analysis services to an oracle database, and when I hit Process in AS, it gives me a generic Failed to save modifications to the server. Error returned: 'OLE DB or ODBC error: [DataSource.Error] Oracle: ORA-12154: TNS:could not resolve the connect identifier specified.

Things I've tried:

  • When I create the tables in VS2017, the connection works
  • When I do a tnsping from the command line, that works
  • I replaced all of the default tnsnames.ora files in ./app with the one that I know works (its what the TNS_ADMIN env variable is set to

I don't see where the location of the actual utilities used by the service are detailed, so I can't test it using those.

How can I make SSAS use the tnsnames.ora file that I need?

1

How can I make SSAS use the tnsnames.ora file that I need?

The best answer is don't bother. Use the Easy Connect naming method, and bypass the TNSNAMES.ORA file entirely.

Alternatively you can set the TNS_ADMIN environment variable to the folder containing your TSNNAMES.ORA file and reboot your server for the SSAS service to see get the changed environment.

  • This does look easier. I have special characters in my password (and no ability to change the password to the account). Is there a way to escape them? For what it's worth, I did reboot the server and still no dice. – soandos Mar 22 '18 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.