5

I cannot run mssql immediately following an apt-get update. Is this due to a bad script (below: The file "C:\Install\SqlTraceCollect.dtsx" does not exist)? Any suggestions on a fix? I'm at a loss.

sudo systemctl start mssql-server
sudo systemctl status mssql-server
● mssql-server.service - Microsoft SQL Server Database Engine
    Loaded: loaded (/lib/systemd/system/mssql-server.service; enabled; vendor preset: enabled)
       Active: active (running)
        ...
sudo systemctl status mssql-server
● mssql-server.service - Microsoft SQL Server Database Engine
    Loaded: loaded (/lib/systemd/system/mssql-server.service; enabled; vendor preset: enabled)
       Active: inactive (dead) (Result: exit-code) since Wed 2018-03-21 22:46:15 PDT; 1min 27s ago
         Docs: https://docs.microsoft.com/en-us/sql/linux
      Process: 2977 ExecStart=/opt/mssql/bin/sqlservr (code=exited, status=255)
     Main PID: 2977 (code=exited, status=255)
    ...
        sudo cat /var/opt/mssql/log/errorlog
        2018-03-21 22:36:24.19 Server      Microsoft SQL Server 2017 (RTM-CU5) (KB4092643) - 14.0.3023.8 (X64)
        ...
        2018-03-21 22:36:35.90 spid6s      Creating SSIS folders...
        ...
        2018-03-21 22:36:35.91 spid6s      Creating procedure [dbo].[sp_syscollector_upload_instmdw]...
        2018-03-21 22:36:35.92 spid6s      Uploading data collector package from disk: C:\Install\SqlTraceCollect.dtsx
        2018-03-21 22:36:35.92 spid6s      Uploading data collector package from disk: C:\Install\SqlTraceCollect.dtsx
        2018-03-21 22:36:35.93 spid6s      Error: 4860, Severity: 16, State: 1.
        2018-03-21 22:36:35.93 spid6s      Cannot bulk load. The file "C:\Install\SqlTraceCollect.dtsx" does not exist or you don't have file access rights.
        2018-03-21 22:36:35.93 spid6s      Error: 912, Severity: 21, State: 2.
        2018-03-21 22:36:35.93 spid6s      Script level upgrade for database 'master' failed because upgrade step 'msdb110_upgrade.sql' encountered error 200, state 7, severity 25. This is a serious error condition which might interfere with regular operation and the database will be taken offline. If the error happened during upgrade of the 'master' database, it will prevent the entire SQL Server instance from starting. Examine the previous errorlog entries for errors, take the appropriate corrective actions and re-start the database so that the script upgrade steps run to completion.
        2018-03-21 22:36:35.95 spid6s      Error: 3417, Severity: 21, State: 3.
        2018-03-21 22:36:35.95 spid6s      Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it, or rebuild it. For more information about how to rebuild the master database, see SQL Server Books Online.
        2018-03-21 22:36:35.96 spid6s      SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.
9

Seems like the only solution is downgrading:

On a Ubuntu server do the following to perform a downgrade to the previous (14.0.3022.28-2) version:

systemctl stop mssql-server
sudo apt-get install mssql-server=14.0.3022.28-2
systemctl start mssql-server

For other linux OS use your package manager or download the package manually from here: https://packages.microsoft.com


Update 2018-03-25:

The support team replied and included a solution for this problem in the release notes:

To resolve this error, enable SQL Server Agent and restart SQL Server with the following commands:

sudo /opt/mssql/bin/mssql-conf set sqlagent.enabled true
sudo systemctl start mssql-server

https://docs.microsoft.com/en-us/sql/linux/sql-server-linux-release-notes#known-upgrade-issue

  • I added sudo apt-mark hold mssql-server to prevent recurrence; thanks very much for the solution – jimmont Mar 22 '18 at 16:46
  • 1
    @jimmont you're welcome; I think you can give it another try now though (see my updated answer). – B12Toaster Mar 25 '18 at 15:29
  • Bleeding edge answer to a bleeding edge update. Perfect. Thank you very much! – David Dombrowsky Mar 27 '18 at 1:19
  • Thanks, the updated answer worked for me, looks like sqlagent.enabled is now required for SQL Server on Ubuntu. – Jaza Apr 3 '18 at 1:26
1

We're using a SQL Server 2017 on a Centos-7 system and there was that same error yesterday, when I made a complete yum update.

The new build number, that I've had for the mssql-server.x86_64 package, was the 14.0.3023.8 with the release date of 2018 March 20 (see here: https://buildnumbers.wordpress.com/sqlserver/).

I downgraded it to 14.0.3022.28-2 with the release date of 2018 February 20, restarted the mssql-server.service and now it's working again.

I've also tried updating again, just to make sure that it's a problem with the update and not only because something went wrong once. But unfortunately, for me it seems to be a problem with the newest update.

To summarise, then, one possible solution may be to downgrade from 14.0.3023.8 to 14.0.3022.28-2.

protected by Community Mar 22 '18 at 12:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.