I am trying to setup MySQL InnoDB Cluster. I am using version 5.7.20 of the MySQL server. I am able to create a cluster. When I try to add the first slave is when I run into my issue. It complains about the slave having group transactions the master does not have. The error is as follows:

This member has more executed transactions than those present in the group. Local Transactions: c5109632-32bb-11e8-a081-005056a142d2:1-5 > Group transactions: a43235a8-32bb-11-e8-97c3-005056a16fa6:1-47, a4c00453-3344-11e8-b0fb-005056a16fa6:1-14

This is fine because I log into the MySQL shell (on the master) and run the follow:

SET GITD_NEXT='c5109632-32bb-11e8-a081-005056a142d2:1'; BEGIN; COMMIT;

I do that for the five ids and then I end with


That gets me past that error, however I get a new error. It is:

Plugin group_replication reported: Group contains 2 members which is greater than group_replication_auto_increment_increment value of 1. This can lead to an higher rate of transactional aborts.

Then I get:

Slave SQL for channel 'group_replication_recovery': Error 'Unknown error 1396' on query. Default database: ''. Query:

When I set all of this up. I created 3 brand new instances on 3 different servers. I created a cluster manager user account "bob" on all 3 instances. I ran all of the grants for that user on all 3 instances. I then did the checkInstanceConfiguration from all 3 instances. They all passed. I then did the configureLocalInstance on all 3 instances. Then I created my cluster and tried adding a slave.

My question is how can I get around the 'group_replication_recovery' SQL error. What did I do wrong?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.