0

When I open DB settings and try to change any setting it throws an error on save:

Property DefaultLanguageName is not available for Database '[TMS-API555]'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

enter image description here

It really does show empty language setting

enter image description here

I tried to reset language via TSQL

EXEC sp_configure 'default language', 2 ;  
GO  
RECONFIGURE ;  
GO  

Configuration option 'default language' changed from 3 to 2. Run the RECONFIGURE statement to install.

After that it still shows empty language and throws the error on save.

Tried

ALTER AUTHORIZATION ON DATABASE::dbname TO [sa];

didn't work

Facts:

  1. I updated SQL Server 2016 to latest available version 13.0.4474.0
  2. Windows Server 2016
  3. Management Studio 14.0.17199.0
  4. Logged in as sysadmin
  5. If I create a new empty DB - there is no error and everything works
1

For a contained database, set the default language with ALTER DATABASE. For example:

ALTER DATABASE [TMS-API555] SET DEFAULT_LANGUAGE = english;
  • Hello, maybe you know I set the language on production DB, then make backup, restore on test server and have language setting not set again and have to update it? – bogert Oct 6 '18 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.