Full disclosure, I'm not a database admin, but if anyone is able to help me, it would be you guys.

Our Oracle 11g database server stopped working, I'm not aware of anything that could have caused it, it was out of the blue. When I try to connect via SQL Developer I get either 'connection reset by peer socket write error' or 'Input/Output error: connection reset.

I've tried restarting it, checked whether the Windows Services are running and went through every item in the configuration that I could have found, but nothing helped. It seems that the listener is unable to start (I've tried adding a new listener with identical setting and also got the socket write error)

Since I've done no changes to the configuration, I'm perplexed what the issue could be. Does anyone has any ideas to what could be the cause of this issue? And if not, can some one post a link to something like the SQL Server's "Repair Installation" which I didn't find?

Any help is appreciated.

EDIT: I was asked for the following:

Output for the lsnrctl status:

    LSNRCTL for 32-bit Windows: Version - Production on 03-JUL-2012 13:30

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
TNS-12571: TNS:packet writer failure
 TNS-12560: TNS:protocol adapter error
  TNS-00530: Protocol adapter error
   32-bit Windows Error: 54: Unknown error

And according to the lsnrctl start, the listener is already running

  • Open a command prompt and do lsnrctl status & post the output. If it's not running, do lsnrctl start and post the error messages. Is it possible that the server host has changed IP address?
    – Philᵀᴹ
    Commented Jul 3, 2012 at 10:40
  • I've added the requested info. As for the IP adresess changing, I've checked and they are the same. Also the IT guys say that they definitely didn't change. Commented Jul 3, 2012 at 11:37
  • I'll have to let someone else help you I'm afraid. I'm a Unix Oracle guy. My Windows-fu is poor. Sorry...
    – Philᵀᴹ
    Commented Jul 3, 2012 at 12:12
  • Yeah I did just that. Commented Jul 3, 2012 at 19:14

1 Answer 1


The windows error 54 is associated with a port busy or problems with the network communication, try editing the listener.ora file and change the port, then restart the listener service (or if you're able to restart the machine, do so).

It looks like that, for some reason, the port 1521 hungs and there's no longer a TNS Listener service listening there.

P.D. if you didn't configured a TNS_ADMIN folder, the listener.ora file must be in the %ORACLE_HOME%\network\admin folder, where the %ORACLE_HOME% is where the product was installed

The Windows error reference is in: http://msdn.microsoft.com/en-us/library/windows/desktop/ms681382(v=vs.85).aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.