-1

I'm a newbie in Linux. I try to install and run MySQL but when I start it it's got failed and this is my logs :

180426 18:01:03 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
180426 18:01:03  InnoDB: Initializing buffer pool, size = 8.0M
180426 18:01:03  InnoDB: Completed initialization of buffer pool
180426 18:01:03  InnoDB: Started; log sequence number 0 44233
180426 18:01:03 [ERROR] /usr/libexec/mysqld: unknown option '--Disabling symbolic-links is recommended to prevent assor$
180426 18:01:03 [ERROR] Aborting

180426 18:01:03  InnoDB: Starting shutdown...
180426 18:01:09  InnoDB: Shutdown completed; log sequence number 0 44233
180426 18:01:09 [Note] /usr/libexec/mysqld: Shutdown complete

What can I do?

I fix above problem But now I got this errors in Log:

2018-04-27T15:51:27.825000Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-04-27T15:51:27.827374Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.22) starting as process 9669 ...
2018-04-27T15:51:27.984517Z 0 [Note] InnoDB: PUNCH HOLE support available
2018-04-27T15:51:27.984546Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-04-27T15:51:27.984555Z 0 [Note] InnoDB: Uses event mutexes
2018-04-27T15:51:27.984563Z 0 [Note] InnoDB: GCC builtin __sync_synchronize() is used for memory barrier
2018-04-27T15:51:27.984570Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-04-27T15:51:27.984578Z 0 [Note] InnoDB: Using Linux native AIO
2018-04-27T15:51:27.984900Z 0 [Note] InnoDB: Number of pools: 1
2018-04-27T15:51:27.985021Z 0 [Note] InnoDB: Using CPU crc32 instructions
2018-04-27T15:51:27.987684Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-04-27T15:51:27.997035Z 0 [Note] InnoDB: Completed initialization of buffer pool
2018-04-27T15:51:28.001190Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-04-27T15:51:28.011286Z 0 [ERROR] InnoDB: The Auto-extending innodb_system data file './ibdata1' is of a different size 640 pages (rounded down to MB) than specified in the .cnf file: initial 768 pages, max 0 (relevant if non-zero) pages!

2018-04-27T15:51:28.011335Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2018-04-27T15:51:28.612062Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2018-04-27T15:51:28.612135Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2018-04-27T15:51:28.612175Z 0 [ERROR] Failed to initialize builtin plugins.
2018-04-27T15:51:28.612190Z 0 [ERROR] Aborting

NEW EDIT

[root@static ~]# sudo service mysqld start
Initializing MySQL database:                               [FAILED]

and /etc/my.cnf content :

# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.7/en/server-configuration-defaults.html

[mysqld]
#
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M
#
# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
explicit_defaults_for_timestamp=1
innodb_force_recovery=1

closed as off-topic by Philᵀᴹ, John aka hot2use, mustaccio, Colin 't Hart, John Eisbrener Nov 5 at 15:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – Philᵀᴹ, John aka hot2use, John Eisbrener
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Look at the first entry in the log - [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more! – Vérace Apr 27 '18 at 21:31
  • @Vérace I do it but this still not working! – M.D Apr 27 '18 at 21:49
  • What's your first warning now then? – Vérace Apr 27 '18 at 22:01
  • @Vérace| [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option – M.D Apr 28 '18 at 10:11
  • @Vérace I add new Edition – M.D Apr 28 '18 at 10:15
0

Looks like maybe a comment in one of the option files (such as /etc/my.cnf and any .cnf file included from that file) has become un-commented. Search through these files for "Disabling symbolic-links is recommended" and make sure there is a comment character (i.e. '#') in front of it, then save the file and try starting mysqld again.

  • i fixed this I have another problem – M.D Apr 27 '18 at 18:17
0

I change /etc/ directory permission to 650 and MySQL run successfully. it's doesn't run cuz the MySQL can't read and write in my.cnf file.

  • MySQL doesn't write to its option files. You changed the whole /etc/ directory? 650 is "rw-r-x---" ... I'd suggest instead chmod 664 /etc/my.cnf and chown root:root /etc/my.cnf which are standard MySQL ownership and permissions. – dbdemon Apr 28 '18 at 11:33
  • I used chmod 650 /etc/ – M.D Apr 28 '18 at 15:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.