0

I have a Distributed AG, but whenever I go to look at the AG Dashboard it says "An error occurred on the Always On Dashboard". When I click for details I get "Object reference not set to an instance of an object."

Is this a known bug? Or is there possibly something about the setup of my DAG that's causing this? I get this error in both

  • SSMS 2016 16.5.3 (build 13.0.16106.4)
  • SSMS 2017 17.4 (build 14.0.17213.0)
  • 1
    Which version of SQL Server are you using, and which specific versions of SSMS? Seems like an SSMS bug if I had to guess. – LowlyDBA May 1 '18 at 13:43
  • @LowlyDBA i may have added that into my question between you reading and writing your comment – DForck42 May 1 '18 at 13:49
  • 1
    I don't see your SQL Server version anywhere, and I was looking for the full version of SSMS, i.e. 17.4 vs 17.6 as it is being updated frequently now and has had its fair share of bugs along the way. – LowlyDBA May 1 '18 at 13:54
  • @LowlyDBA Yes..recently SSMS updates are actually causing more issues than fixing it. I too second you on the version issue. Use latest SSMS version and check. – Ramakant Dadhichi May 1 '18 at 14:00
  • @LowlyDBA updated – DForck42 May 1 '18 at 14:10
2

As a couple users mentioned in the comments, if you are not actually having problems with the AG, this is likely a bug with SSMS.

You mentioned you're on 17.4, and I see in the release notes for 17.6 that there are several fixes for AG issues, including:

Fixed an issue when the primary is down and manually failover to secondary, a NullReferenceException will be thrown.

(a NullReferenceException in .NET classically includes the message you mentioned - "Object reference not set to an instance of an object")

You should try updating to 17.6 (build 14.0.17230.0) to see if the problem is resolved there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.