0

I have 3 config servers 1 primary and 2 secondaries i have received Waring alerts in secondary servers as

Log File Monitoring : key = error, File = /var/log/mongodb/mongod.log (mgdb09:log[/var/log/mongodb/mongod.log,@mongodb_error,UTF-8]): 2018-05-05T05:42:08.913+0900 W REPL [rsBackgroundSync] Fetcher stopped querying remote oplog with error: InvalidSyncSource: sync source mgdb08:27019 (last visible optime: { ts: Timestamp 1525466619000|1, t: 24 }; config version: 1; sync source index: -1; primary index: 1) is no longer valid

Log File Monitoring : key = error, File = /var/log/mongodb/mongod.log (mgdb07:log[/var/log/mongodb/mongod.log,@mongodb_error,UTF-8]): 2018-05-05T05:37:19.219+0900 W REPL [rsBackgroundSync] Fetcher stopped querying remote oplog with error: InvalidSyncSource: sync source mgdb08:27019 (last visible optime: { ts: Timestamp 1525466619000|1, t: 24 }; config version: 1; sync source index: -1; primary index: 2) is no longer valid

. Log File Monitoring : key = error, File = /var/log/mongodb/mongod.log (mgdb09:log[/var/log/mongodb/mongod.log,@mongodb_error,UTF-8]): 2018-05-05T05:42:13.911+0900 I REPL [SyncSourceFeedback] SyncSourceFeedback error sending update to mgdb08:27019: InvalidSyncSource: Sync source was cleared. Was mgdb08:27019

and later on one of the secondary became primary

what cause this kind of issue what action do i need

  • Welcome to the site. Could you update MongoDB version(x,y,z)? – Md Haidar Ali Khan May 6 '18 at 4:12
1

As I am able to see in your error log file such as error Fetcher stopped querying remote oplog with error: InvalidSyncSource: sync source

As per MongoDB jira documentation here It seems that the common cause for the remote replSetUpdatePosition failing with those error codes NodeNotFound,NotMasterOrSecondary and InvalidReplicaSetConfig would be a change in config. Config changes currently will cause the oplog fetcher to fail because it will detect a change in the config version contained in the oplog query metadata. Subsequently, after exiting the oplog fetcher, we will go back to the sync source resolver which has its own blacklisting logic.

For your further ref here

  • mongodb version is 3.3 – bvk May 7 '18 at 7:41
  • so will this cause any issue – bvk May 7 '18 at 7:42
  • @askh,What is your MongoDB version(x,y,z)? Which you have your config server configuration? – Md Haidar Ali Khan May 7 '18 at 7:45
  • Mongodb version is 3.4.3 – bvk May 7 '18 at 7:58
  • So your config server have higher version than rest of cluster? – JJussi May 7 '18 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.