1

I have configured mariadb galera cluster as docker swarm service using official docker image: during cluster startup rsync (default SST method) works fine. Wanted to change it to xtrabackup or xtrabackup-v2, so used the following configuration in my.cnf according to docs:

[mysqld]
wsrep_sst_auth = <wsrep_sst_user>:<password>
wsrep_sst_method = xtrabackup-v2 (or xtrabackup)
datadir = /var/lib/mysql/

[client]
socket =/var/run/mysqld/mysqld.sock

donor server starts fine, but getting the errors below during joiner server startup:

2018-05-07 13:08:26 139750451541760 [Warning] WSREP: Gap in state sequence. Need state transfer. 2018-05-07 13:08:26 139750232831744 [Note] WSREP: Running: 'wsrep_sst_xtrabackup-v2 --role 'joiner' --address '10.0.0.37' --datadir '/var/lib/mysql/' --parent '108' '' ' WSREP_SST: [INFO] Logging all stderr of SST/Innobackupex to syslog (20180507 13:08:26.937)

2018-05-07 13:08:29 139750249850624 [Note] WSREP: (fdead878, 'tcp://0.0.0.0:4567') turning message relay requesting off

2018-05-07 13:10:07 139750232831744 [ERROR] WSREP: Failed to read 'ready ' from: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '10.0.0.37' --datadir '/var/lib/mysql/' --parent '108' '' Read: '(null)'

2018-05-07 13:10:07 139750232831744 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '10.0.0.37' --datadir '/var/lib/mysql/' --parent '108' '' : 32 (Broken pipe)

2018-05-07 13:10:07 139750451541760 [ERROR] WSREP: Failed to prepare for 'xtrabackup-v2' SST. Unrecoverable. 2018-05-07 13:10:07 139750451541760 [ERROR] Aborting

Error in my_thread_global_end(): 1 threads didn't exit

Other wsrep values:

wsrep_on=ON 
wsrep_provider=/usr/lib/libgalera_smm.so 
wsrep_cluster_address=gcomm:// (for first node to start, and virtual_ip of the first node on 2 other nodes)

How to configure xtrabackup as SST method in MariaDB correctly?

  • Exactly which version of MariaDB is this? There have been several bugs with the xtrabackup SST methods in the earlier 10.1 and 10.2 versions. – dbdemon May 7 '18 at 14:06
  • 1
    It would also be helpful if you could post your other wsrep variables from your .cnf files (my.cnf, server.cnf, ...). – dbdemon May 7 '18 at 14:22
  • 10.2.13+maria~jessie, posted – user1264304 May 7 '18 at 15:23
1

The two scripts (or maybe just the last one, but you need both) /usr/bin/wsrep_sst_common and /usr/bin/wsrep_sst_xtrabackup-v2 are broken in 10.2.13, but you can get fixed versions from bug ticket MDEV-15254.

  • updated MariaDB to 10.2.14 and it helped, thanks – user1264304 May 8 '18 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.