9
  • I've created a Credential Cred1 (DOMAIN\USER1 with the secret = domain password)
  • I've created a SQL Agent job with owner to NT AUTHORITY\SYSTEM
  • The job needs to proxy as credential Cred1

So when I run the job it fails with the message that NT AUTHORITY\SYSTEM wasn't allowed to proxy 1 (I only have one credential) for CmdExec.

"Unable to start the execution of step1 (reason: JobOwner NT AUTHORITY\SYStem doesn't have permissions to use proxy 1"

I've done a bit of google search for the permissions needed, and I read that I need to give operator access to the NT AUTHORITY\SYSTEM login in the MSDB. I've tried this but still no luck.

2 Answers 2

11

Expand SQL Agent
Expand Proxies
Find your proxy, right-click on it and choose Properties
Go to the Principals tab
Add the NT AUTHORITY\SYSTEM account

This will give that account permission to use the proxy.

1
  • Thank you! I had to delete the existing proxy and recreate it as it was suffering a Object Null Reference Exception in the UI until then. When I tried to script this - also get a UI exception. BUt I've achieved what I need. Thank you again. Jul 10, 2012 at 4:28
8

Check select * from msdb.dbo.sysproxies if your proxy is enabled, we had a similar problem and we recreated the proxy with enabled = 1.

That seem to have solved the problem with this error.

2
  • 2
    You can update it to enabled rather than dropping and recreating if that's easier. Mar 6, 2019 at 21:33
  • this helped us with a mystifying " JobOwner sa doesn't have permissions to use proxy" -- but if you try grant access to 'sa' it says sa already has permissions to any proxy
    – Mark Sowul
    Jul 13, 2023 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.